summaryrefslogtreecommitdiff
path: root/src/script/api/CMakeLists.txt
diff options
context:
space:
mode:
authordP <dp@dpointer.org>2021-09-25 14:39:40 +0300
committerGitHub <noreply@github.com>2021-09-25 13:39:40 +0200
commit39662aabefa851a153b66571a50fd4b78b83ced1 (patch)
tree9498197df55f57c9abb28234dd336f82f5b627bb /src/script/api/CMakeLists.txt
parent66c7d9b8ed9df8de1fc1e5b6c83808683bc6bbd2 (diff)
downloadopenttd-39662aabefa851a153b66571a50fd4b78b83ced1.tar.xz
Add: allow gamescripts to build neutral objects (#9568)
Diffstat (limited to 'src/script/api/CMakeLists.txt')
-rw-r--r--src/script/api/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/script/api/CMakeLists.txt b/src/script/api/CMakeLists.txt
index a6390e2bb..b7e0e3014 100644
--- a/src/script/api/CMakeLists.txt
+++ b/src/script/api/CMakeLists.txt
@@ -182,6 +182,8 @@ add_files(
script_newgrf.hpp
script_news.hpp
script_object.hpp
+ script_objecttype.hpp
+ script_objecttypelist.hpp
script_order.hpp
script_priorityqueue.hpp
script_rail.hpp
@@ -250,6 +252,8 @@ add_files(
script_newgrf.cpp
script_news.cpp
script_object.cpp
+ script_objecttype.cpp
+ script_objecttypelist.cpp
script_order.cpp
script_priorityqueue.cpp
script_rail.cpp