summaryrefslogtreecommitdiff
path: root/src/misc/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-01-16 16:43:34 +0100
committerMichael Lutz <michi@icosahedron.de>2021-02-22 22:16:07 +0100
commit1e1a9f39994bf6b4053a423f2b064b917fee402c (patch)
tree1bf80741987b9d15b66fa09d0609a0950b50c315 /src/misc/CMakeLists.txt
parent3e49aff35c49190ee9f9f18fcef8db7175d0559a (diff)
downloadopenttd-1e1a9f39994bf6b4053a423f2b064b917fee402c.tar.xz
Add: A simple, templated cache map that uses a least recently used eviction strategy.
Diffstat (limited to 'src/misc/CMakeLists.txt')
-rw-r--r--src/misc/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/misc/CMakeLists.txt b/src/misc/CMakeLists.txt
index 3a5363e7b..9ed598004 100644
--- a/src/misc/CMakeLists.txt
+++ b/src/misc/CMakeLists.txt
@@ -10,5 +10,6 @@ add_files(
getoptdata.cpp
getoptdata.h
hashtable.hpp
+ lrucache.hpp
str.hpp
)