summaryrefslogtreecommitdiff
path: root/src/blitter/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-01-16 16:43:44 +0100
committerMichael Lutz <michi@icosahedron.de>2021-02-22 22:16:07 +0100
commit94d8acb7d007150606c0756060c6f0cf90ee7f70 (patch)
tree57d5c1399f5eaa8005daf0d85ae86cb10a48cda8 /src/blitter/CMakeLists.txt
parentae7c63cc35362932500f42f4a11ae2160566b718 (diff)
downloadopenttd-94d8acb7d007150606c0756060c6f0cf90ee7f70.tar.xz
Add: A 32 bpp blitter that uses the animation buffer from the video backend to speed up palette animation.
Diffstat (limited to 'src/blitter/CMakeLists.txt')
-rw-r--r--src/blitter/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/blitter/CMakeLists.txt b/src/blitter/CMakeLists.txt
index 0aff38141..ddcc9a008 100644
--- a/src/blitter/CMakeLists.txt
+++ b/src/blitter/CMakeLists.txt
@@ -32,6 +32,13 @@ add_files(
CONDITION NOT OPTION_DEDICATED AND SSE_FOUND
)
+add_files(
+ 40bpp_anim.cpp
+ 40bpp_anim.hpp
+ CONDITION NOT OPTION_DEDICATED AND OPENGL_FOUND
+)
+
+
if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang" OR CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang")
set_compile_flags(
32bpp_anim_sse2.cpp