summaryrefslogtreecommitdiff
path: root/src/3rdparty/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-01-16 16:43:17 +0100
committerMichael Lutz <michi@icosahedron.de>2021-02-22 22:16:07 +0100
commit9a069faa0135b02f3ea8601594e174ada73fcd74 (patch)
treecc700f120b89b9ae1b1bc05434826a8eb6f48848 /src/3rdparty/opengl/CMakeLists.txt
parenta990c497b5dfbb51f8196a874eb4cb29b4933328 (diff)
downloadopenttd-9a069faa0135b02f3ea8601594e174ada73fcd74.tar.xz
Codechange: [Win32] Try to get an OpenGL 3.2+ context if possible.
Diffstat (limited to 'src/3rdparty/opengl/CMakeLists.txt')
-rw-r--r--src/3rdparty/opengl/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/3rdparty/opengl/CMakeLists.txt b/src/3rdparty/opengl/CMakeLists.txt
index 86069c33d..6176d252f 100644
--- a/src/3rdparty/opengl/CMakeLists.txt
+++ b/src/3rdparty/opengl/CMakeLists.txt
@@ -3,3 +3,8 @@ add_files(
glext.h
CONDITION OPENGL_FOUND
)
+
+add_files(
+ wglext.h
+ CONDITION WIN32 AND OPENGL_FOUND
+)