summaryrefslogtreecommitdiff
path: root/os/debian
diff options
context:
space:
mode:
authormatthijs <matthijs@openttd.org>2008-09-03 16:47:54 +0000
committermatthijs <matthijs@openttd.org>2008-09-03 16:47:54 +0000
commit1c3b4c8a545ebdda625957d32918a9bda75a4ab1 (patch)
treeaa022b7b180abd2958e850302c931fcb4cfeed10 /os/debian
parent7b78084150cf9b07d18e4e1e879630153a7e57e3 (diff)
downloadopenttd-1c3b4c8a545ebdda625957d32918a9bda75a4ab1.tar.xz
(svn r14237) -Feature [Debian]: Allow the Debian packaging to change the package name of the resulting package.
- The name can be changed at build time, by changing the package name in debian/changelog. - This will allow packages like openttd-svn or openttd-cargodest packages to be built.
Diffstat (limited to 'os/debian')
-rw-r--r--os/debian/control.in (renamed from os/debian/control)4
-rwxr-xr-xos/debian/rules29
2 files changed, 25 insertions, 8 deletions
diff --git a/os/debian/control b/os/debian/control.in
index a0d6ee1c6..0f7fd14dc 100644
--- a/os/debian/control
+++ b/os/debian/control.in
@@ -1,4 +1,4 @@
-Source: openttd
+Source: PACKAGE
Section: contrib/games
Priority: optional
Maintainer: Matthijs Kooijman <m.kooijman@student.utwente.nl>
@@ -6,7 +6,7 @@ Uploaders: Jordi Mallach <jordi@debian.org>
Build-Depends: debhelper (>= 4.0.0), dpatch, libsdl-dev, zlib1g-dev, libpng-dev, libfreetype6-dev, libfontconfig-dev
Standards-Version: 3.7.2
-Package: openttd
+Package: PACKAGE
Architecture: any
Depends: ${shlibs:Depends}, debconf
Suggests: timidity, freepats
diff --git a/os/debian/rules b/os/debian/rules
index afc687f7c..af070f62a 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -6,9 +6,24 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEFAULT_PACKAGE := openttd
+# Find the package name from the topmost changelog entry.
+# Is this the best way to do this?
+PACKAGE = $(shell cat debian/changelog | head -1 | cut -f1 -d' ')
+
include /usr/share/dpatch/dpatch.make
-configure: patch configure-stamp
+debian/control:
+ # Generate control file
+ sed 's/PACKAGE/$(PACKAGE)/' debian/control.in > debian/control
+
+ # TODO: How to do this using makefile conditionals?
+ if [ "$(PACKAGE)" != "$(DEFAULT_PACKAGE)" ]; then \
+ echo "Provides: $(DEFAULT_PACKAGE)" >> debian/control ; \
+ echo "Conflicts: $(DEFAULT_PACKAGE)" >> debian/control ; \
+ fi;
+
+configure: debian/control patch configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
@@ -16,20 +31,20 @@ configure-stamp:
touch configure-stamp
-build: configure build-stamp
+build: debian/control configure build-stamp
build-stamp:
dh_testdir
# Add here commands to compile the package.
- ./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/openttd
+ ./configure --prefix-dir=/usr --binary-dir=games --data-dir=share/games/openttd --icon-dir=share/pixmaps --personal-dir=.openttd --install-dir=debian/$(PACKAGE)
$(MAKE)
#/usr/bin/docbook-to-man debian/openttd.sgml > openttd.1
touch build-stamp
-clean: unpatch
+clean: debian/control unpatch
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
@@ -38,8 +53,10 @@ clean: unpatch
-$(MAKE) clean
dh_clean
+ # Clean up generated control file
+ -rm debian/control
-install: build
+install: debian/control build
dh_testdir
dh_testroot
dh_clean -k
@@ -53,7 +70,7 @@ binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch: debian/control build install
dh_testdir
dh_testroot
dh_installchangelogs changelog.txt