summaryrefslogtreecommitdiff
path: root/os/debian/rules
diff options
context:
space:
mode:
authorrubidium <rubidium@openttd.org>2010-10-27 16:42:20 +0000
committerrubidium <rubidium@openttd.org>2010-10-27 16:42:20 +0000
commit59519edd344b3e9fa7d8f9f768563e8533d3760b (patch)
tree3c68e8041adb9395345d0330e80b36686d0d8e02 /os/debian/rules
parent5ad2265c1d7f36d17ac157bd4e5e722a6a2355d3 (diff)
downloadopenttd-59519edd344b3e9fa7d8f9f768563e8533d3760b.tar.xz
(svn r21044) -Feature: XZ/LZMA2 savegame support. New default reduces savegame size by 10 to 30% with slightly more CPU usage. With maximum settings it reduces savegame size by 20 to 30%, but that takes 7 to 14 times longer. Map saving + downloading takes, on average, 5% less.
Diffstat (limited to 'os/debian/rules')
-rwxr-xr-xos/debian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/os/debian/rules b/os/debian/rules
index 5b852fbe1..92056a2bc 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -17,7 +17,7 @@ endif
# to be explicit about the dependencies, in case we're not running in a
# clean build root.
override_dh_auto_configure:
- ./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --without-iconv --disable-strip CFLAGS="$(CFLAGS) -g"
+ ./configure $(CROSS) --prefix-dir=/usr --install-dir=debian/openttd --without-allegro --with-zlib --with-sdl --with-png --with-freetype --with-fontconfig --with-icu --with-liblzo2 --with-lzma --without-iconv --disable-strip CFLAGS="$(CFLAGS) -g"
# Do some extra installation
override_dh_auto_install: