summaryrefslogtreecommitdiff
path: root/os/debian/rules
diff options
context:
space:
mode:
authormatthijs <matthijs@openttd.org>2006-03-08 23:12:38 +0000
committermatthijs <matthijs@openttd.org>2006-03-08 23:12:38 +0000
commitba5172d0f4f6a958a2ba0ca7d024834f52092756 (patch)
tree830d598ae433c64fbd3dfb39064e75deea4e2b1d /os/debian/rules
parent602e5670745bf40f9a9a8946e37ba739540eb501 (diff)
downloadopenttd-ba5172d0f4f6a958a2ba0ca7d024834f52092756.tar.xz
(svn r3801) * Update debian packaging files to the ones used for releasing 0.4.5 (see os/debian/changelog for details).
* Fix a small debconf issue which was in the 0.4.5 release.
Diffstat (limited to 'os/debian/rules')
-rwxr-xr-xos/debian/rules24
1 files changed, 6 insertions, 18 deletions
diff --git a/os/debian/rules b/os/debian/rules
index cc4ea34cc..06902342f 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -6,20 +6,9 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/dpatch/dpatch.make
-#not supported by openttd makefile
-#CFLAGS = -Wall -g
-#
-#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-# CFLAGS += -O0
-#else
-# CFLAGS += -O2
-#endif
-#ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-# INSTALL_PROGRAM += -s
-#endif
-
-configure: configure-stamp
+configure: patch configure-stamp
configure-stamp:
dh_testdir
# Add here commands to configure the package.
@@ -28,20 +17,19 @@ configure-stamp:
build: build-stamp
-
-build-stamp: configure-stamp
+build-stamp: configure-stamp
dh_testdir
# Add here commands to compile the package.
rm Makefile.config || true
- $(MAKE) PREFIX=/usr MIDI=/usr/bin/timidity INSTALL=1 BINARY_DIR=games DATA_DIR=share/games/openttd PERSONAL_DIR=.openttd USE_HOMEDIR=1
+ $(MAKE) PREFIX=/usr MIDI=/usr/bin/timidity INSTALL=1 BINARY_DIR=games DATA_DIR=share/games/openttd ICON_DIR=share/pixmaps PERSONAL_DIR=.openttd USE_HOMEDIR=1
#/usr/bin/docbook-to-man debian/openttd.sgml > openttd.1
touch build-stamp
-clean:
+clean: unpatch
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
@@ -74,7 +62,7 @@ binary-arch: build install
dh_installexamples
# dh_install
dh_installmenu
-# dh_installdebconf
+ dh_installdebconf
# dh_installlogrotate
# dh_installemacsen
# dh_installpam