summaryrefslogtreecommitdiff
path: root/os/debian/rules
diff options
context:
space:
mode:
authormatthijs <matthijs@openttd.org>2006-12-21 14:44:19 +0000
committermatthijs <matthijs@openttd.org>2006-12-21 14:44:19 +0000
commitd88e549d9f140507eb5786d68878b4983bd67493 (patch)
tree7d0adb81e2a8b11937801d48aaf14f357f8fa1f6 /os/debian/rules
parent29ed5e55c7812cb222e038db0018ba972a9bcc59 (diff)
downloadopenttd-d88e549d9f140507eb5786d68878b4983bd67493.tar.xz
(svn r7533) -Codechange [Debian]: Update debian packaging files
- Update to latest standards version. - Fix rules to compile only once.
Diffstat (limited to 'os/debian/rules')
-rwxr-xr-xos/debian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/os/debian/rules b/os/debian/rules
index 06902342f..baf162076 100755
--- a/os/debian/rules
+++ b/os/debian/rules
@@ -16,8 +16,8 @@ configure-stamp:
touch configure-stamp
-build: build-stamp
-build-stamp: configure-stamp
+build: configure build-stamp
+build-stamp:
dh_testdir
# Add here commands to compile the package.
@@ -38,12 +38,12 @@ clean: unpatch
-$(MAKE) clean
rm Makefile.config || true
- dh_clean
+ dh_clean
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_clean -k
dh_installdirs
# Add here commands to install the package into debian/openttd.
@@ -85,4 +85,4 @@ binary-arch: build install
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install configure patch