summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2021-02-06 22:58:51 +0100
committerMichael Lutz <michi@icosahedron.de>2021-02-13 22:21:17 +0100
commit43326d11d8861721c9db45922bc7d42cf99dccba (patch)
tree6dad3b348bdb1f54449702adaf1b7b36d0b92971 /CMakeLists.txt
parent2a8c3a2cf6460f8abb6032a449bf4cd4be01e847 (diff)
downloadopenttd-43326d11d8861721c9db45922bc7d42cf99dccba.tar.xz
Change: [OSX] Use a layer-backed view to speed up drawing.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c5d7ac113..2af3d30da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,6 +131,7 @@ if(NOT WIN32)
find_library(AUDIOTOOLBOX_LIBRARY AudioToolbox)
find_library(AUDIOUNIT_LIBRARY AudioUnit)
find_library(COCOA_LIBRARY Cocoa)
+ find_library(QUARTZCORE_LIBRARY QuartzCore)
endif()
endif()
@@ -163,6 +164,9 @@ if(APPLE)
if(NOT COCOA_LIBRARY)
message(FATAL_ERROR "Cocoa is required for this platform")
endif()
+ if(NOT QUARTZCORE_LIBRARY)
+ message(FATAL_ERROR "QuartzCore is required for this platform")
+ endif()
endif()
if(OPTION_PACKAGE_DEPENDENCIES)
@@ -250,6 +254,7 @@ if(APPLE)
${AUDIOTOOLBOX_LIBRARY}
${AUDIOUNIT_LIBRARY}
${COCOA_LIBRARY}
+ ${QUARTZCORE_LIBRARY}
)
add_definitions(