summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorglx22 <glx@openttd.org>2021-02-05 02:00:36 +0100
committerLoïc Guilloux <glx22@users.noreply.github.com>2021-02-07 16:21:13 +0100
commit2cbfcd232758967fa84794967d71d9584ec799ec (patch)
tree0d0845a9c91260e07fdc0557c52f744f62a27803 /CMakeLists.txt
parentb927da73c1c2e354731b410e02f4b98b1b311ae1 (diff)
downloadopenttd-2cbfcd232758967fa84794967d71d9584ec799ec.tar.xz
Change: [CMake] Bump minimum version to 3.9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 3 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be544316d..8fbf3507d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.9)
if(NOT BINARY_NAME)
set(BINARY_NAME openttd)
@@ -143,13 +143,8 @@ find_package(Xaudio2)
find_package(Grfcodec)
-# IPO is only properly supported from CMake 3.9. Despite the fact we are
-# CMake 3.5, still enable IPO if we detect we are 3.9+.
-if(POLICY CMP0069)
- cmake_policy(SET CMP0069 NEW)
- include(CheckIPOSupported)
- check_ipo_supported(RESULT IPO_FOUND)
-endif()
+include(CheckIPOSupported)
+check_ipo_supported(RESULT IPO_FOUND)
show_options()