summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Lutz <michi@icosahedron.de>2020-07-05 14:39:39 +0200
committerMichael Lutz <michi@icosahedron.de>2020-07-10 19:33:00 +0200
commit00eccbe298ad7f7d656e121ce58c2a6326dabe2f (patch)
treee0ad9e862c9651c25ccacdc78cf8ff165442b696 /CMakeLists.txt
parentdb0bf20fbbcdbe98c5c0fcac8c38c18cf9419fd1 (diff)
downloadopenttd-00eccbe298ad7f7d656e121ce58c2a6326dabe2f.tar.xz
Add: [CMake] Source group definitions to create file filters in generated project files (like the old MSVC projects).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 364236c86..1400179ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,6 +131,8 @@ include_directories(${CMAKE_SOURCE_DIR}/src)
# Needed by everything that uses Squirrel
include_directories(${CMAKE_SOURCE_DIR}/src/3rdparty/squirrel/include)
+include(MSVCFilters)
+
include(CompileFlags)
compile_flags()