summaryrefslogtreecommitdiff
path: root/tests/sort/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/sort/Makefile.am')
-rw-r--r--tests/sort/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/sort/Makefile.am b/tests/sort/Makefile.am
index 21d301d33..cfadf64a9 100644
--- a/tests/sort/Makefile.am
+++ b/tests/sort/Makefile.am
@@ -63,9 +63,9 @@ check: $(maint_gen)
$(srcdir)/Makefile.am: ../Makefile.am.in Test.pm $(mk_script)
rm -f $@ $@t
- sed -n '1,/^##test-files-begin/p' $< > $@t
+ sed -n '1,/^##test-files-begin/p' $(srcdir)/../Makefile.am.in > $@t
tool=`echo $(subdir)|sed 's/^tests.//;s/-test//'`; \
echo "x = $$tool" >> $@t
$(PERL) -I$(srcdir) -w -- $(mk_script) $(srcdir) --list >> $@t
- sed -n '/^##test-files-end/,$$p' $< >> $@t
+ sed -n '/^##test-files-end/,$$p' $(srcdir)/../Makefile.am.in >> $@t
mv $@t $@