summaryrefslogtreecommitdiff
path: root/tests/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/misc/Makefile.am')
-rw-r--r--tests/misc/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/misc/Makefile.am b/tests/misc/Makefile.am
index 7425a6b07..5f256cfa2 100644
--- a/tests/misc/Makefile.am
+++ b/tests/misc/Makefile.am
@@ -26,7 +26,14 @@ built_programs = \
# will expand 'if test ...' to 'if .../test ...', and the '.../test'
# will execute the test script rather than the standard utility.
+# Ordering:
+# help-version comes early because it's a basic sanity test.
+# Put seq early, since lots of other tests use it.
+# Put head-elide-tail early, because it's long-running.
+
TESTS = \
+ help-version \
+ seq \
head-elide-tail \
ls-time \
ls-misc \
@@ -64,7 +71,6 @@ TESTS = \
groups-version \
head-c \
head-pos \
- help-version \
md5sum \
md5sum-newline \
mknod \
@@ -80,7 +86,6 @@ TESTS = \
pwd-long \
readlink-fp-loop \
runcon-no-reorder \
- seq \
sha1sum \
sha1sum-vec \
sha224sum \