summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am989
1 files changed, 496 insertions, 493 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ff0af8494..a547b1181 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -45,7 +45,7 @@ check_DATA = .built-programs
&& MAKEFLAGS= $(MAKE) -s built_programs.list) \
> $@-t && mv $@-t $@
-TEST_EXTENSIONS = .xpl
+TEST_EXTENSIONS = .sh .pl .xpl
if HAVE_PERL
TESTSUITE_PERL = $(PERL)
@@ -63,6 +63,9 @@ LOG_COMPILER = \
--test-name "$$f" --srcdir '$(srcdir)' \
--shell '$(SHELL)' --perl '$(TESTSUITE_PERL)' --
+PL_LOG_COMPILER = $(LOG_COMPILER)
+SH_LOG_COMPILER = $(LOG_COMPILER)
+
# Perl scripts that must be run in tainted mode.
XPL_LOG_COMPILER = \
$(TESTSUITE_PERL) -wT -I$(srcdir) -MCoreutils -MCuSkip -M"CuTmpdir qw($$f)"
@@ -131,32 +134,32 @@ EXTRA_DIST = \
$(pr_data)
root_tests = \
- chown/basic \
- cp/cp-a-selinux \
- cp/preserve-gid \
- cp/special-bits \
- cp/cp-mv-enotsup-xattr \
- cp/capability \
- cp/sparse-fiemap \
- dd/skip-seek-past-dev \
- df/problematic-chars \
- du/bind-mount-dir-cycle \
- install/install-C-root \
- ls/capability \
- ls/nameless-uid \
- misc/chcon \
- misc/chroot-credentials \
- misc/id-setgid \
- misc/selinux \
- misc/truncate-owned-by-other \
- mkdir/writable-under-readonly \
- mv/sticky-to-xpart \
- rm/fail-2eperm \
- rm/no-give-up \
- rm/one-file-system \
- rm/read-only \
- tail-2/append-only \
- touch/now-owned-by-other
+ chown/basic.sh \
+ cp/cp-a-selinux.sh \
+ cp/preserve-gid.sh \
+ cp/special-bits.sh \
+ cp/cp-mv-enotsup-xattr.sh \
+ cp/capability.sh \
+ cp/sparse-fiemap.sh \
+ dd/skip-seek-past-dev.sh \
+ df/problematic-chars.sh \
+ du/bind-mount-dir-cycle.sh \
+ install/install-C-root.sh \
+ ls/capability.sh \
+ ls/nameless-uid.sh \
+ misc/chcon.sh \
+ misc/chroot-credentials.sh \
+ misc/id-setgid.sh \
+ misc/selinux.sh \
+ misc/truncate-owned-by-other.sh \
+ mkdir/writable-under-readonly.sh \
+ mv/sticky-to-xpart.sh \
+ rm/fail-2eperm.sh \
+ rm/no-give-up.sh \
+ rm/one-file-system.sh \
+ rm/read-only.sh \
+ tail-2/append-only.sh \
+ touch/now-owned-by-other.sh
.PHONY: check-root
check-root:
@@ -191,473 +194,473 @@ EXTRA_DIST += $(TESTS)
# Put head-elide-tail early, because it's long-running.
TESTS = \
- misc/help-version \
- tail-2/inotify-race \
- misc/invalid-opt \
- rm/ext3-perf \
- rm/cycle \
- cp/link-heap \
- misc/tty-eof \
- tail-2/inotify-hash-abuse \
- tail-2/inotify-hash-abuse2 \
- tail-2/F-vs-missing \
- tail-2/F-vs-rename \
- tail-2/inotify-rotate \
- chmod/no-x \
- chgrp/basic \
- rm/dangling-symlink \
- misc/ls-time \
- rm/d-1 \
- rm/d-2 \
- rm/d-3 \
- rm/deep-1 \
- rm/deep-2 \
- rm/dir-no-w \
- rm/dir-nonrecur \
- rm/dot-rel \
- rm/isatty \
- rm/empty-inacc \
- rm/empty-name \
- rm/f-1 \
- rm/fail-eacces \
+ misc/help-version.sh \
+ tail-2/inotify-race.sh \
+ misc/invalid-opt.pl \
+ rm/ext3-perf.sh \
+ rm/cycle.sh \
+ cp/link-heap.sh \
+ misc/tty-eof.pl \
+ tail-2/inotify-hash-abuse.sh \
+ tail-2/inotify-hash-abuse2.sh \
+ tail-2/F-vs-missing.sh \
+ tail-2/F-vs-rename.sh \
+ tail-2/inotify-rotate.sh \
+ chmod/no-x.sh \
+ chgrp/basic.sh \
+ rm/dangling-symlink.sh \
+ misc/ls-time.sh \
+ rm/d-1.sh \
+ rm/d-2.sh \
+ rm/d-3.sh \
+ rm/deep-1.sh \
+ rm/deep-2.sh \
+ rm/dir-no-w.sh \
+ rm/dir-nonrecur.sh \
+ rm/dot-rel.sh \
+ rm/isatty.sh \
+ rm/empty-inacc.sh \
+ rm/empty-name.pl \
+ rm/f-1.sh \
+ rm/fail-eacces.sh \
rm/fail-eperm.xpl \
- tail-2/assert \
- rm/hash \
- rm/i-1 \
- rm/i-never \
- rm/i-no-r \
- tail-2/infloop-1 \
- rm/ignorable \
- rm/inaccessible \
- rm/interactive-always \
- rm/interactive-once \
- rm/ir-1 \
- rm/one-file-system2 \
- rm/r-1 \
- rm/r-2 \
- rm/r-3 \
- rm/r-4 \
- rm/readdir-bug \
- rm/rm1 \
- touch/empty-file \
- rm/rm2 \
- rm/rm3 \
- rm/rm4 \
- rm/rm5 \
- rm/sunos-1 \
- rm/unread2 \
- rm/unread3 \
- rm/unreadable \
- rm/v-slash \
- rm/many-dir-entries-vs-OOM \
- chgrp/default-no-deref \
- chgrp/deref \
- chgrp/no-x \
- chgrp/posix-H \
- chgrp/recurse \
- fmt/base \
- fmt/long-line \
- fmt/goal-option \
- misc/env \
- misc/ptx \
- misc/test \
- misc/seq \
- misc/seq-long-double \
- misc/head \
- misc/head-elide-tail \
- tail-2/tail-n0f \
- misc/ls-misc \
- misc/date \
- misc/date-next-dow \
- misc/ptx-overrun \
- misc/xstrtol \
- tail-2/pid \
- misc/od \
- misc/od-float \
- misc/mktemp \
- misc/arch \
- misc/pr \
- misc/join \
- pr/pr-tests \
- misc/pwd-option \
- misc/chcon-fail \
- misc/cut \
- misc/wc \
- misc/wc-files0-from \
- misc/wc-files0 \
- misc/wc-parallel \
- misc/cat-proc \
- misc/cat-buf \
- misc/base64 \
- misc/basename \
- misc/close-stdout \
- misc/chroot-fail \
- misc/comm \
- misc/csplit \
- misc/csplit-1000 \
- misc/csplit-heap \
- misc/date-sec \
- misc/dircolors \
- misc/dirname \
- misc/env-null \
- misc/expand \
- misc/expr \
- misc/factor \
- misc/false-status \
- misc/fold \
- misc/groups-dash \
- misc/groups-version \
- misc/head-c \
- misc/head-pos \
- misc/id-context \
- misc/id-groups \
- misc/id-setgid \
- misc/md5sum \
- misc/md5sum-bsd \
- misc/md5sum-newline \
- misc/md5sum-parallel \
- misc/mknod \
- misc/nice \
- misc/nice-fail \
- misc/nl \
- misc/nohup \
- misc/nproc-avail \
- misc/nproc-positive \
- misc/od-N \
- misc/od-multiple-t \
- misc/od-x8 \
- misc/paste \
- misc/pathchk1 \
- misc/printenv \
- misc/printf \
- misc/printf-cov \
- misc/printf-hex \
- misc/printf-surprise \
- misc/pwd-long \
- misc/readlink-fp-loop \
- misc/readlink-root \
- misc/realpath \
- misc/runcon-no-reorder \
- misc/sha1sum \
- misc/sha1sum-vec \
- misc/sha224sum \
- misc/sha256sum \
- misc/sha384sum \
- misc/sha512sum \
- misc/shred-exact \
- misc/shred-passes \
- misc/shred-remove \
- misc/shuf \
- misc/sort \
- misc/sort-benchmark-random \
- misc/sort-compress \
- misc/sort-compress-hang \
- misc/sort-compress-proc \
- misc/sort-continue \
- misc/sort-debug-keys \
- misc/sort-debug-warn \
- misc/sort-discrim \
- misc/sort-files0-from \
- misc/sort-float \
- misc/sort-merge \
- misc/sort-merge-fdlimit \
- misc/sort-month \
- misc/sort-exit-early \
- misc/sort-rand \
- misc/sort-spinlock-abuse \
- misc/sort-stale-thread-mem \
- misc/sort-unique \
- misc/sort-unique-segv \
- misc/sort-version \
- misc/sort-NaN-infloop \
- misc/sort-u-FMR \
- split/filter \
- split/suffix-auto-length \
- split/suffix-length \
- split/additional-suffix \
- split/b-chunk \
- split/fail \
- split/lines \
- split/l-chunk \
- split/r-chunk \
- split/numeric \
- split/guard-input \
- misc/stat-birthtime \
- misc/stat-fmt \
- misc/stat-hyphen \
- misc/stat-mount \
- misc/stat-nanoseconds \
- misc/stat-printf \
- misc/stat-slash \
- misc/stdbuf \
- misc/stty \
- misc/stty-invalid \
- misc/stty-pairs \
- misc/stty-row-col \
- misc/sum \
- misc/sum-sysv \
- misc/tac \
- misc/tac-continue \
- misc/tac-2-nonseekable \
- misc/tail \
- misc/tee \
- misc/tee-dash \
- misc/test-diag \
- misc/timeout \
- misc/timeout-group \
- misc/timeout-parameters \
- misc/tr \
- misc/tr-case-class \
- misc/truncate-dangling-symlink \
- misc/truncate-dir-fail \
- misc/truncate-fail-diag \
- misc/truncate-fifo \
- misc/truncate-no-create-missing \
- misc/truncate-overflow \
- misc/truncate-parameters \
- misc/truncate-relative \
- misc/tsort \
- misc/unexpand \
- misc/uniq \
- misc/uniq-perf \
- misc/xattr \
- tail-2/wait \
- chmod/c-option \
- chmod/equal-x \
- chmod/equals \
- chmod/inaccessible \
- chmod/octal \
- chmod/setgid \
- chmod/silent \
- chmod/thru-dangling \
- chmod/umask-x \
- chmod/usage \
- chown/deref \
- chown/preserve-root \
- chown/separator \
- cp/abuse \
- cp/acl \
- cp/attr-existing \
- cp/backup-1 \
- cp/backup-dir \
- cp/backup-is-src \
- cp/cp-HL \
- cp/cp-deref \
- cp/cp-i \
- cp/cp-mv-backup \
- cp/cp-parents \
- cp/deref-slink \
- cp/dir-rm-dest \
- cp/dir-slash \
- cp/dir-vs-file \
- cp/existing-perm-dir \
- cp/existing-perm-race \
- cp/fail-perm \
- cp/fiemap-empty \
- cp/fiemap-perf \
- cp/fiemap-2 \
- cp/file-perm-race \
- cp/into-self \
- cp/link \
- cp/link-no-deref \
- cp/link-preserve \
- cp/link-symlink \
- cp/nfs-removal-race \
- cp/no-deref-link1 \
- cp/no-deref-link2 \
- cp/no-deref-link3 \
- cp/parent-perm \
- cp/parent-perm-race \
- cp/perm \
- cp/preserve-2 \
- cp/preserve-link \
- cp/preserve-slink-time \
- cp/proc-short-read \
- cp/proc-zero-len \
- cp/r-vs-symlink \
- cp/reflink-auto \
- cp/reflink-perm \
- cp/same-file \
- cp/slink-2-slink \
- cp/sparse \
- cp/sparse-to-pipe \
- cp/special-f \
- cp/src-base-dot \
- cp/symlink-slash \
- cp/thru-dangling \
- df/header \
- df/df-P \
- df/unreadable \
- df/total-unprocessed \
- df/no-mtab-status \
- dd/direct \
- dd/misc \
- dd/nocache \
- dd/not-rewound \
- dd/reblock \
- dd/skip-seek \
- dd/skip-seek2 \
- dd/bytes \
- dd/skip-seek-past-file \
- dd/sparse \
- dd/stderr \
- dd/unblock \
- dd/unblock-sync \
- df/total-verify \
- du/2g \
- du/8gb \
- du/basic \
- du/bigtime \
- du/deref \
- du/deref-args \
- du/exclude \
- du/fd-leak \
- du/files0-from \
- du/files0-from-dir \
- du/hard-link \
- du/inacc-dest \
- du/inacc-dir \
- du/inaccessible-cwd \
- du/long-from-unreadable \
- du/long-sloop \
- du/max-depth \
- du/move-dir-while-traversing \
- du/no-deref \
- du/no-x \
- du/one-file-system \
- du/restore-wd \
- du/slash \
- du/slink \
- du/trailing-slash \
- du/two-args \
- id/gnu-zero-uids \
- id/no-context \
- install/basic-1 \
- install/create-leading \
- install/d-slashdot \
- install/install-C \
- install/install-C-selinux \
- install/strip-program \
- install/trap \
- ln/backup-1 \
- ln/hard-backup \
- ln/hard-to-sym \
- ln/misc \
- ln/relative \
- ln/sf-1 \
- ln/slash-decorated-nonexistent-dest \
- ln/target-1 \
- ls/abmon-align \
- ls/block-size \
- ls/color-clear-to-eol \
- ls/color-dtype-dir \
- ls/color-norm \
- ls/dangle \
- ls/dired \
- ls/file-type \
- ls/follow-slink \
- ls/getxattr-speedup \
- ls/infloop \
- ls/inode \
- ls/m-option \
- ls/multihardlink \
- ls/no-arg \
- ls/no-cap \
- ls/proc-selinux-segfault \
- ls/readdir-mountpoint-inode \
- ls/recursive \
- ls/root-rel-symlink-color \
- ls/rt-1 \
- ls/slink-acl \
- ls/stat-dtype \
- ls/stat-failed \
- ls/stat-free-color \
- ls/stat-free-symlinks \
- ls/stat-vs-dirent \
- ls/symlink-slash \
- ls/time-style-diag \
- ls/x-option \
- mkdir/p-1 \
- mkdir/p-2 \
- mkdir/p-3 \
- mkdir/p-slashdot \
- mkdir/p-thru-slink \
- mkdir/p-v \
- mkdir/parents \
- mkdir/perm \
- mkdir/selinux \
- mkdir/special-1 \
- mkdir/t-slash \
- mv/acl \
- mv/atomic \
- mv/atomic2 \
- mv/backup-dir \
- mv/backup-is-src \
- mv/childproof \
- mv/diag \
- mv/dir-file \
- mv/dir2dir \
- mv/dup-source \
- mv/force \
- mv/hard-2 \
- mv/hard-3 \
- mv/hard-4 \
- mv/hard-link-1 \
- mv/hard-verbose \
- mv/i-1 \
- mv/i-2 \
- mv/i-3 \
- mv/i-4 \
- mv/i-5 \
- mv/i-link-no \
- mv/into-self \
- mv/into-self-2 \
- mv/into-self-3 \
- mv/into-self-4 \
- mv/leak-fd \
- mv/mv-n \
- mv/mv-special-1 \
- mv/no-target-dir \
- mv/part-fail \
- mv/part-hardlink \
- mv/part-rename \
- mv/part-symlink \
- mv/partition-perm \
- mv/perm-1 \
- mv/symlink-onto-hardlink \
- mv/symlink-onto-hardlink-to-self \
- mv/to-symlink \
- mv/trailing-slash \
- mv/update \
- readlink/can-e \
- readlink/can-f \
- readlink/can-m \
- readlink/rl-1 \
- rmdir/fail-perm \
- rmdir/ignore \
- rmdir/t-slash \
- tail-2/assert-2 \
- tail-2/big-4gb \
- tail-2/flush-initial \
- tail-2/follow-name \
- tail-2/follow-stdin \
- tail-2/pipe-f \
- tail-2/pipe-f2 \
- tail-2/proc-ksyms \
- tail-2/start-middle \
- touch/60-seconds \
- touch/dangling-symlink \
- touch/dir-1 \
- touch/fail-diag \
- touch/fifo \
- touch/no-create-missing \
- touch/no-dereference \
- touch/no-rights \
- touch/not-owner \
- touch/obsolescent \
- touch/read-only \
- touch/relative \
- touch/trailing-slash \
+ tail-2/assert.sh \
+ rm/hash.sh \
+ rm/i-1.sh \
+ rm/i-never.sh \
+ rm/i-no-r.sh \
+ tail-2/infloop-1.sh \
+ rm/ignorable.sh \
+ rm/inaccessible.sh \
+ rm/interactive-always.sh \
+ rm/interactive-once.sh \
+ rm/ir-1.sh \
+ rm/one-file-system2.sh \
+ rm/r-1.sh \
+ rm/r-2.sh \
+ rm/r-3.sh \
+ rm/r-4.sh \
+ rm/readdir-bug.sh \
+ rm/rm1.sh \
+ touch/empty-file.sh \
+ rm/rm2.sh \
+ rm/rm3.sh \
+ rm/rm4.sh \
+ rm/rm5.sh \
+ rm/sunos-1.sh \
+ rm/unread2.sh \
+ rm/unread3.sh \
+ rm/unreadable.pl \
+ rm/v-slash.sh \
+ rm/many-dir-entries-vs-OOM.sh \
+ chgrp/default-no-deref.sh \
+ chgrp/deref.sh \
+ chgrp/no-x.sh \
+ chgrp/posix-H.sh \
+ chgrp/recurse.sh \
+ fmt/base.pl \
+ fmt/long-line.sh \
+ fmt/goal-option.sh \
+ misc/env.sh \
+ misc/ptx.pl \
+ misc/test.pl \
+ misc/seq.pl \
+ misc/seq-long-double.sh \
+ misc/head.pl \
+ misc/head-elide-tail.pl \
+ tail-2/tail-n0f.sh \
+ misc/ls-misc.pl \
+ misc/date.pl \
+ misc/date-next-dow.pl \
+ misc/ptx-overrun.sh \
+ misc/xstrtol.pl \
+ tail-2/pid.sh \
+ misc/od.pl \
+ misc/od-float.sh \
+ misc/mktemp.pl \
+ misc/arch.sh \
+ misc/pr.pl \
+ misc/join.pl \
+ pr/pr-tests.pl \
+ misc/pwd-option.sh \
+ misc/chcon-fail.sh \
+ misc/cut.pl \
+ misc/wc.pl \
+ misc/wc-files0-from.pl \
+ misc/wc-files0.sh \
+ misc/wc-parallel.sh \
+ misc/cat-proc.sh \
+ misc/cat-buf.sh \
+ misc/base64.pl \
+ misc/basename.pl \
+ misc/close-stdout.sh \
+ misc/chroot-fail.sh \
+ misc/comm.pl \
+ misc/csplit.sh \
+ misc/csplit-1000.sh \
+ misc/csplit-heap.sh \
+ misc/date-sec.sh \
+ misc/dircolors.pl \
+ misc/dirname.pl \
+ misc/env-null.sh \
+ misc/expand.pl \
+ misc/expr.pl \
+ misc/factor.pl \
+ misc/false-status.sh \
+ misc/fold.pl \
+ misc/groups-dash.sh \
+ misc/groups-version.sh \
+ misc/head-c.sh \
+ misc/head-pos.sh \
+ misc/id-context.sh \
+ misc/id-groups.sh \
+ misc/id-setgid.sh \
+ misc/md5sum.pl \
+ misc/md5sum-bsd.sh \
+ misc/md5sum-newline.pl \
+ misc/md5sum-parallel.sh \
+ misc/mknod.sh \
+ misc/nice.sh \
+ misc/nice-fail.sh \
+ misc/nl.sh \
+ misc/nohup.sh \
+ misc/nproc-avail.sh \
+ misc/nproc-positive.sh \
+ misc/od-N.sh \
+ misc/od-multiple-t.sh \
+ misc/od-x8.sh \
+ misc/paste.pl \
+ misc/pathchk1.sh \
+ misc/printenv.sh \
+ misc/printf.sh \
+ misc/printf-cov.pl \
+ misc/printf-hex.sh \
+ misc/printf-surprise.sh \
+ misc/pwd-long.sh \
+ misc/readlink-fp-loop.sh \
+ misc/readlink-root.sh \
+ misc/realpath.sh \
+ misc/runcon-no-reorder.sh \
+ misc/sha1sum.pl \
+ misc/sha1sum-vec.pl \
+ misc/sha224sum.pl \
+ misc/sha256sum.pl \
+ misc/sha384sum.pl \
+ misc/sha512sum.pl \
+ misc/shred-exact.sh \
+ misc/shred-passes.sh \
+ misc/shred-remove.sh \
+ misc/shuf.sh \
+ misc/sort.pl \
+ misc/sort-benchmark-random.sh \
+ misc/sort-compress.sh \
+ misc/sort-compress-hang.sh \
+ misc/sort-compress-proc.sh \
+ misc/sort-continue.sh \
+ misc/sort-debug-keys.sh \
+ misc/sort-debug-warn.sh \
+ misc/sort-discrim.sh \
+ misc/sort-files0-from.pl \
+ misc/sort-float.sh \
+ misc/sort-merge.pl \
+ misc/sort-merge-fdlimit.sh \
+ misc/sort-month.sh \
+ misc/sort-exit-early.sh \
+ misc/sort-rand.sh \
+ misc/sort-spinlock-abuse.sh \
+ misc/sort-stale-thread-mem.sh \
+ misc/sort-unique.sh \
+ misc/sort-unique-segv.sh \
+ misc/sort-version.sh \
+ misc/sort-NaN-infloop.sh \
+ misc/sort-u-FMR.sh \
+ split/filter.sh \
+ split/suffix-auto-length.sh \
+ split/suffix-length.sh \
+ split/additional-suffix.sh \
+ split/b-chunk.sh \
+ split/fail.sh \
+ split/lines.sh \
+ split/l-chunk.sh \
+ split/r-chunk.sh \
+ split/numeric.sh \
+ split/guard-input.sh \
+ misc/stat-birthtime.sh \
+ misc/stat-fmt.sh \
+ misc/stat-hyphen.sh \
+ misc/stat-mount.sh \
+ misc/stat-nanoseconds.sh \
+ misc/stat-printf.pl \
+ misc/stat-slash.sh \
+ misc/stdbuf.sh \
+ misc/stty.sh \
+ misc/stty-invalid.sh \
+ misc/stty-pairs.sh \
+ misc/stty-row-col.sh \
+ misc/sum.pl \
+ misc/sum-sysv.sh \
+ misc/tac.pl \
+ misc/tac-continue.sh \
+ misc/tac-2-nonseekable.sh \
+ misc/tail.pl \
+ misc/tee.sh \
+ misc/tee-dash.sh \
+ misc/test-diag.pl \
+ misc/timeout.sh \
+ misc/timeout-group.sh \
+ misc/timeout-parameters.sh \
+ misc/tr.pl \
+ misc/tr-case-class.sh \
+ misc/truncate-dangling-symlink.sh \
+ misc/truncate-dir-fail.sh \
+ misc/truncate-fail-diag.sh \
+ misc/truncate-fifo.sh \
+ misc/truncate-no-create-missing.sh \
+ misc/truncate-overflow.sh \
+ misc/truncate-parameters.sh \
+ misc/truncate-relative.sh \
+ misc/tsort.pl \
+ misc/unexpand.pl \
+ misc/uniq.pl \
+ misc/uniq-perf.sh \
+ misc/xattr.sh \
+ tail-2/wait.sh \
+ chmod/c-option.sh \
+ chmod/equal-x.sh \
+ chmod/equals.sh \
+ chmod/inaccessible.sh \
+ chmod/octal.sh \
+ chmod/setgid.sh \
+ chmod/silent.sh \
+ chmod/thru-dangling.sh \
+ chmod/umask-x.sh \
+ chmod/usage.sh \
+ chown/deref.sh \
+ chown/preserve-root.sh \
+ chown/separator.sh \
+ cp/abuse.sh \
+ cp/acl.sh \
+ cp/attr-existing.sh \
+ cp/backup-1.sh \
+ cp/backup-dir.sh \
+ cp/backup-is-src.sh \
+ cp/cp-HL.sh \
+ cp/cp-deref.sh \
+ cp/cp-i.sh \
+ cp/cp-mv-backup.sh \
+ cp/cp-parents.sh \
+ cp/deref-slink.sh \
+ cp/dir-rm-dest.sh \
+ cp/dir-slash.sh \
+ cp/dir-vs-file.sh \
+ cp/existing-perm-dir.sh \
+ cp/existing-perm-race.sh \
+ cp/fail-perm.sh \
+ cp/fiemap-empty.sh \
+ cp/fiemap-perf.sh \
+ cp/fiemap-2.sh \
+ cp/file-perm-race.sh \
+ cp/into-self.sh \
+ cp/link.sh \
+ cp/link-no-deref.sh \
+ cp/link-preserve.sh \
+ cp/link-symlink.sh \
+ cp/nfs-removal-race.sh \
+ cp/no-deref-link1.sh \
+ cp/no-deref-link2.sh \
+ cp/no-deref-link3.sh \
+ cp/parent-perm.sh \
+ cp/parent-perm-race.sh \
+ cp/perm.sh \
+ cp/preserve-2.sh \
+ cp/preserve-link.sh \
+ cp/preserve-slink-time.sh \
+ cp/proc-short-read.sh \
+ cp/proc-zero-len.sh \
+ cp/r-vs-symlink.sh \
+ cp/reflink-auto.sh \
+ cp/reflink-perm.sh \
+ cp/same-file.sh \
+ cp/slink-2-slink.sh \
+ cp/sparse.sh \
+ cp/sparse-to-pipe.sh \
+ cp/special-f.sh \
+ cp/src-base-dot.sh \
+ cp/symlink-slash.sh \
+ cp/thru-dangling.sh \
+ df/header.sh \
+ df/df-P.sh \
+ df/unreadable.sh \
+ df/total-unprocessed.sh \
+ df/no-mtab-status.sh \
+ dd/direct.sh \
+ dd/misc.sh \
+ dd/nocache.sh \
+ dd/not-rewound.sh \
+ dd/reblock.sh \
+ dd/skip-seek.pl \
+ dd/skip-seek2.sh \
+ dd/bytes.sh \
+ dd/skip-seek-past-file.sh \
+ dd/sparse.sh \
+ dd/stderr.sh \
+ dd/unblock.pl \
+ dd/unblock-sync.sh \
+ df/total-verify.sh \
+ du/2g.sh \
+ du/8gb.sh \
+ du/basic.sh \
+ du/bigtime.sh \
+ du/deref.sh \
+ du/deref-args.sh \
+ du/exclude.sh \
+ du/fd-leak.sh \
+ du/files0-from.pl \
+ du/files0-from-dir.sh \
+ du/hard-link.sh \
+ du/inacc-dest.sh \
+ du/inacc-dir.sh \
+ du/inaccessible-cwd.sh \
+ du/long-from-unreadable.sh \
+ du/long-sloop.sh \
+ du/max-depth.sh \
+ du/move-dir-while-traversing.sh \
+ du/no-deref.sh \
+ du/no-x.sh \
+ du/one-file-system.sh \
+ du/restore-wd.sh \
+ du/slash.sh \
+ du/slink.sh \
+ du/trailing-slash.sh \
+ du/two-args.sh \
+ id/gnu-zero-uids.sh \
+ id/no-context.sh \
+ install/basic-1.sh \
+ install/create-leading.sh \
+ install/d-slashdot.sh \
+ install/install-C.sh \
+ install/install-C-selinux.sh \
+ install/strip-program.sh \
+ install/trap.sh \
+ ln/backup-1.sh \
+ ln/hard-backup.sh \
+ ln/hard-to-sym.sh \
+ ln/misc.sh \
+ ln/relative.sh \
+ ln/sf-1.sh \
+ ln/slash-decorated-nonexistent-dest.sh \
+ ln/target-1.sh \
+ ls/abmon-align.sh \
+ ls/block-size.sh \
+ ls/color-clear-to-eol.sh \
+ ls/color-dtype-dir.sh \
+ ls/color-norm.sh \
+ ls/dangle.sh \
+ ls/dired.sh \
+ ls/file-type.sh \
+ ls/follow-slink.sh \
+ ls/getxattr-speedup.sh \
+ ls/infloop.sh \
+ ls/inode.sh \
+ ls/m-option.sh \
+ ls/multihardlink.sh \
+ ls/no-arg.sh \
+ ls/no-cap.sh \
+ ls/proc-selinux-segfault.sh \
+ ls/readdir-mountpoint-inode.sh \
+ ls/recursive.sh \
+ ls/root-rel-symlink-color.sh \
+ ls/rt-1.sh \
+ ls/slink-acl.sh \
+ ls/stat-dtype.sh \
+ ls/stat-failed.sh \
+ ls/stat-free-color.sh \
+ ls/stat-free-symlinks.sh \
+ ls/stat-vs-dirent.sh \
+ ls/symlink-slash.sh \
+ ls/time-style-diag.sh \
+ ls/x-option.sh \
+ mkdir/p-1.sh \
+ mkdir/p-2.sh \
+ mkdir/p-3.sh \
+ mkdir/p-slashdot.sh \
+ mkdir/p-thru-slink.sh \
+ mkdir/p-v.sh \
+ mkdir/parents.sh \
+ mkdir/perm.sh \
+ mkdir/selinux.sh \
+ mkdir/special-1.sh \
+ mkdir/t-slash.sh \
+ mv/acl.sh \
+ mv/atomic.sh \
+ mv/atomic2.sh \
+ mv/backup-dir.sh \
+ mv/backup-is-src.sh \
+ mv/childproof.sh \
+ mv/diag.sh \
+ mv/dir-file.sh \
+ mv/dir2dir.sh \
+ mv/dup-source.sh \
+ mv/force.sh \
+ mv/hard-2.sh \
+ mv/hard-3.sh \
+ mv/hard-4.sh \
+ mv/hard-link-1.sh \
+ mv/hard-verbose.sh \
+ mv/i-1.pl \
+ mv/i-2.sh \
+ mv/i-3.sh \
+ mv/i-4.sh \
+ mv/i-5.sh \
+ mv/i-link-no.sh \
+ mv/into-self.sh \
+ mv/into-self-2.sh \
+ mv/into-self-3.sh \
+ mv/into-self-4.sh \
+ mv/leak-fd.sh \
+ mv/mv-n.sh \
+ mv/mv-special-1.sh \
+ mv/no-target-dir.sh \
+ mv/part-fail.sh \
+ mv/part-hardlink.sh \
+ mv/part-rename.sh \
+ mv/part-symlink.sh \
+ mv/partition-perm.sh \
+ mv/perm-1.sh \
+ mv/symlink-onto-hardlink.sh \
+ mv/symlink-onto-hardlink-to-self.sh \
+ mv/to-symlink.sh \
+ mv/trailing-slash.sh \
+ mv/update.sh \
+ readlink/can-e.sh \
+ readlink/can-f.sh \
+ readlink/can-m.sh \
+ readlink/rl-1.sh \
+ rmdir/fail-perm.sh \
+ rmdir/ignore.sh \
+ rmdir/t-slash.sh \
+ tail-2/assert-2.sh \
+ tail-2/big-4gb.sh \
+ tail-2/flush-initial.sh \
+ tail-2/follow-name.sh \
+ tail-2/follow-stdin.sh \
+ tail-2/pipe-f.sh \
+ tail-2/pipe-f2.sh \
+ tail-2/proc-ksyms.sh \
+ tail-2/start-middle.sh \
+ touch/60-seconds.sh \
+ touch/dangling-symlink.sh \
+ touch/dir-1.sh \
+ touch/fail-diag.sh \
+ touch/fifo.sh \
+ touch/no-create-missing.sh \
+ touch/no-dereference.sh \
+ touch/no-rights.sh \
+ touch/not-owner.sh \
+ touch/obsolescent.sh \
+ touch/read-only.sh \
+ touch/relative.sh \
+ touch/trailing-slash.sh \
$(root_tests)
pr_data = \