summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f36e13803..c12b9d986 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -148,6 +148,7 @@ noinst_HEADERS = \
fiemap.h \
find-mount-point.h \
fs.h \
+ fs-is-local.h \
group-list.h \
ioblksize.h \
ls.h \
@@ -597,6 +598,14 @@ fs-kernel-magic: Makefile
| LC_ALL=C sort \
> $@-t && mv $@-t $@
+BUILT_SOURCES += fs-is-local.h
+fs-is-local.h: stat.c extract-magic
+ $(AM_V_GEN)rm -f $@
+ $(AM_V_at)$(PERL) $(srcdir)/extract-magic --local $(srcdir)/stat.c \
+ > $@t
+ $(AM_V_at)chmod a-w $@t
+ $(AM_V_at)mv $@t $@
+
BUILT_SOURCES += fs.h
fs.h: stat.c extract-magic
$(AM_V_GEN)rm -f $@