summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 80313ae4b..362587885 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -466,6 +466,9 @@ sc_tight_scope: $(all_programs)
exit 1; } || :
# Use the just-built ./ginstall, when not cross-compiling.
-if !CROSS_COMPILING
-INSTALL_PROGRAM = ./ginstall
+if CROSS_COMPILING
+cu_install_program = @INSTALL_PROGRAM@
+else
+cu_install_program = ./ginstall
endif
+INSTALL_PROGRAM = $(cu_install_program)