summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 906e80479..ee16a3ff2 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -154,7 +154,7 @@ mapped_name = `echo $*|sed 's/^install$$/ginstall/; s/^test$$/[/'`
'or inadequate' 1>&2 \
;; \
*) \
- rm -f $@ \
+ rm -f $@ $@-t \
&& { \
rm -rf $t; \
mkdir $t; \
@@ -164,8 +164,11 @@ mapped_name = `echo $*|sed 's/^install$$/ginstall/; s/^test$$/[/'`
--include=$(srcdir)/$*.x \
--output=$t/$@ $t/$*; \
} \
- && sed 's|$*\.td/||g' $t/$@ > $@ \
- && rm -rf $t ;; \
+ && sed 's|$*\.td/||g' $t/$@ > $@-t \
+ && rm -rf $t \
+ && chmod -w $@-t \
+ && mv $@-t $@ \
+ ;; \
esac
distcheck-hook: check-x-vs-1 check-programs-vs-x