summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79b50892d..820587564 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,9 +70,12 @@ BUILT_SOURCES = .version
.version:
echo $(VERSION) > $@-t && mv $@-t $@
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
# The perl substitution is to change some key uses of "rm" to "/bin/rm".
# See the rm_subst comment for details.
dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
perl -pi -e '$(rm_subst)' $(distdir)/src/Makefile.in
distcheck-hook: