summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-09-13 12:13:35 +0200
committerJim Meyering <jim@meyering.net>2007-09-15 18:59:08 +0200
commitd96a863cf5131c71a19ab88c683c7251de22b598 (patch)
tree4c9aca4b25c9953a74f96aa62e832d76d381d2c2 /tests/rm/Makefile.am
parent56f1bd10fc1f2c0d7b72a4e016a45ab12b896901 (diff)
downloadcoreutils-d96a863cf5131c71a19ab88c683c7251de22b598.tar.xz
Enable some previously omitted test scripts. Add a test cross-check.
* tests/rm/Makefile.am (TESTS): Add empty-name and unreadable. * tests/rm/empty-name: Likewise. * tests/rm/unreadable: Reenable this test. Adjust for new rm. * tests/mkdir/Makefile.am: Add writable-under-readonly. * tests/mkdir/writable-under-readonly: Add some comments. This test is always skipped, for now. * tests/Makefile.am (ta): Hook up the new root-only script. * tests/tail-2/infloop-1: Make this test pass. * tests/tail-2/Makefile.am (TESTS): Add infloop-1. * tests/tail-2/fflush: Remove unused file. * tests/check.mk (vc_executable_is_in_TESTS): More portable. * tests/check.mk (check): Depend on the above. * build-aux/check.mk: Remove comment mentioning AUTHORS file.
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index 203fe36a6..f29274744 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -33,12 +33,15 @@ TESTS = \
unread3 \
no-give-up \
dir-no-w \
+ empty-name \
fail-2eperm \
cycle i-no-r fail-eperm \
rm1 rm2 rm3 rm4 rm5 \
unread2 r-1 r-2 r-3 r-4 i-1 ir-1 f-1 sunos-1 \
+ unreadable \
interactive-always interactive-once \
- isatty # unreadable empty-name
+ isatty
+
EXTRA_DIST = $(TESTS)
TESTS_ENVIRONMENT = \
RM=../../src/rm \