summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>1998-10-25 14:08:38 +0000
committerJim Meyering <jim@meyering.net>1998-10-25 14:08:38 +0000
commitc729fe037e53dbf623a41336df1088dba08eb5cf (patch)
tree2d908dc046141ac5746f65f64266361709900645 /tests/rm/Makefile.am
parent02cde32c0a1287432e315b57bb1af43555c72841 (diff)
downloadcoreutils-c729fe037e53dbf623a41336df1088dba08eb5cf.tar.xz
(TESTS): Add new test `unreadable'. But comment
it out since we're so close to release and since the test compares the text of diagnostics that are likely to vary between systems. (TEST_ENVIRONMENT): Add required framework.
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index 3dfdeee50..d10c92485 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -1,6 +1,13 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-.
AUTOMAKE_OPTIONS = 1.1 gnits
-TESTS = r-1 r-2 r-3 i-1 ir-1 f-1 sunos-1 deep-1
+TESTS = r-1 r-2 r-3 i-1 ir-1 f-1 sunos-1 deep-1 # unreadable
EXTRA_DIST = $(TESTS)
-TESTS_ENVIRONMENT = RM=../../src/rm MKDIR=../../src/mkdir
+TESTS_ENVIRONMENT = \
+ RM=../../src/rm \
+ MKDIR=../../src/mkdir \
+ top_srcdir=$(top_srcdir) \
+ srcdir=$(srcdir) \
+ PERL="@PERL@" \
+ PATH=../../src:$$PATH \
+ PROG=rm