summaryrefslogtreecommitdiff
path: root/tests/rm/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-09-29 09:54:24 +0000
committerJim Meyering <jim@meyering.net>2006-09-29 09:54:24 +0000
commita4d470409f5590b95d33ab67e5866ab71e4f0e27 (patch)
tree063eddc8b35a52abf51ae0d9e99483029015d5cd /tests/rm/Makefile.am
parent344c4467768879d21f90b27bad10dc98c764d349 (diff)
downloadcoreutils-a4d470409f5590b95d33ab67e5866ab71e4f0e27.tar.xz
Work around a readdir bug in Darwin 7.9.0 (MacOS X 10.3.9) on HFS+
and NFS, whereby rm would not remove all files in a directory. * src/remove.c (CONSECUTIVE_READDIR_UNLINK_THRESHOLD): Reduce to 10. (NEED_REWIND): New macro, so that we incur the cost of the work-around rewinddir only on afflicted systems. * NEWS: Clarify and correct. * tests/rm/readdir-bug: New file. Test for the above fix. * tests/rm/Makefile.am (TESTS): Add it. Prompted by testing and analysis from Bruno Haible: http://lists.gnu.org/archive/html/bug-coreutils/2006-09/msg00326.html
Diffstat (limited to 'tests/rm/Makefile.am')
-rw-r--r--tests/rm/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/rm/Makefile.am b/tests/rm/Makefile.am
index 958b03ef6..8fc7bcab8 100644
--- a/tests/rm/Makefile.am
+++ b/tests/rm/Makefile.am
@@ -21,6 +21,7 @@
AUTOMAKE_OPTIONS = 1.1 gnits
TESTS = \
+ readdir-bug \
empty-inacc \
dir-nonrecur \
dot-rel \