summaryrefslogtreecommitdiff
path: root/tests/mv/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-10-05 10:55:26 +0200
committerJim Meyering <meyering@redhat.com>2007-10-05 13:26:46 +0200
commitb4148f567d9bf7abc8e82a6f2e252f28da93f354 (patch)
treec02cabad7e804828d02acc5875bf9ae10f303a27 /tests/mv/Makefile.am
parent068fa34adcb846244c81704de2872102310de86e (diff)
downloadcoreutils-b4148f567d9bf7abc8e82a6f2e252f28da93f354.tar.xz
Make a failing cross-partition mv give a sensible diagnostic.
A cross-partition move of a file in a sticky tmpdir and owned by another user would evoke an invalid diagnostic after copying it: mv: cannot remove `x': Operation not permitted Either of the following (mv.c, remove.c) changes would fix the bug by itself. I think it's slightly better to use both; the added cost is minimal: mv: an extra lstat-per-mv-cmdline-arg-that-goes-cross-partition, rm: an extra lstat-per-unlink-that-fails-w/EPERM. * src/remove.c (remove_entry): Also lstat the file upon EPERM. * src/mv.c (rm_option_init): Initialize root_dev_ino just as is done in rm, so that a cross-partition invoked remove.c:rm call works the same way as one invoked from the command-line use of "rm". That setting of root_dev_ino makes rm() do the equivalent of an additional lstat for each argument, which in turn gives rm enough information to issue the right diagnostic. * tests/mv/sticky-to-xpart (version): New file. Test for the above. * tests/mv/Makefile.am (TESTS): Add sticky-to-xpart. Arrange for "make check-root" to run the new root-only test. * tests/Makefile.am (tb): New target, to run the new root-only test. (all_t): Add tb. * src/c99-to-c89.diff: Adjust offsets.
Diffstat (limited to 'tests/mv/Makefile.am')
-rw-r--r--tests/mv/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/mv/Makefile.am b/tests/mv/Makefile.am
index 4fa09fbd2..ba5d41d98 100644
--- a/tests/mv/Makefile.am
+++ b/tests/mv/Makefile.am
@@ -17,6 +17,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
TESTS = \
+ sticky-to-xpart \
hard-verbose \
backup-dir \
dir2dir \