summaryrefslogtreecommitdiff
path: root/tests/mv/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2006-09-20 17:32:14 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2006-09-20 17:32:14 +0000
commit2a01141018637fc06604335aea673dff95efd033 (patch)
tree4cf78e6c99e09e4a5d947e465b92829fc7a43bae /tests/mv/Makefile.am
parentfae30e1af9aec9486b0a278c1c5e7b8c6abba498 (diff)
downloadcoreutils-2a01141018637fc06604335aea673dff95efd033.tar.xz
* NEWS: Document fix for cp -i and mv -i.
* src/copy.c (copy_internal): With -i, prompt even if the source is a directory and the destination is not. This is required by POSIX and gives the user a chance to bail out before failing. * tests/cp/Makefile.am (TESTS): Add cp-i. * tests/cp/cp-i: New file. * tests/mv/Makefile.am (TESTS): Add i-5. * tests/mv/i-5: New file.
Diffstat (limited to 'tests/mv/Makefile.am')
-rw-r--r--tests/mv/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/mv/Makefile.am b/tests/mv/Makefile.am
index b5294b4e2..01db2285c 100644
--- a/tests/mv/Makefile.am
+++ b/tests/mv/Makefile.am
@@ -36,7 +36,7 @@ TESTS = \
perm-1 \
i-link-no \
part-fail \
- dup-source childproof i-4 update i-2 mv-special-1 \
+ dup-source childproof i-4 i-5 update i-2 mv-special-1 \
into-self into-self-2 into-self-3 into-self-4 \
backup-is-src \
i-1 hard-link-1 force partition-perm to-symlink dir-file diag \