summaryrefslogtreecommitdiff
path: root/tests/ls/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-07-21 08:49:24 +0000
committerJim Meyering <jim@meyering.net>2006-07-21 08:49:24 +0000
commit9e0a095be648284bdc8a47d2b01120fdb01c001f (patch)
treecb0053ddc797acfd3d54826a0112653883a3063c /tests/ls/Makefile.am
parent2060c55141708d2ff09cc34d27c0a2a856a21c28 (diff)
downloadcoreutils-9e0a095be648284bdc8a47d2b01120fdb01c001f.tar.xz
Fix another bug: ls --indicator-style=file-type would call
stat for a symlink, even though it wasn't always needed. In some cases, that unnecessary stat would cause ls to fail. * src/ls.c (gobble_file): Don't treat symlinks specially (in requiring a stat syscall). Remove the offending exclusion. * NEWS: Mention the fix. * tests/ls/stat-dtype: New file/test, for the above fix. Also exercises the new df feature, below.
Diffstat (limited to 'tests/ls/Makefile.am')
-rw-r--r--tests/ls/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/ls/Makefile.am b/tests/ls/Makefile.am
index 87f20405f..7c6ae5ab0 100644
--- a/tests/ls/Makefile.am
+++ b/tests/ls/Makefile.am
@@ -3,6 +3,7 @@
AUTOMAKE_OPTIONS = 1.2 gnits
TESTS = \
+ stat-dtype \
inode dangle file-type recursive dired infloop \
rt-1 time-1 symlink-slash follow-slink no-arg m-option \
stat-vs-dirent