summaryrefslogtreecommitdiff
path: root/tests/ls/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-08-26 06:46:17 +0000
committerJim Meyering <jim@meyering.net>2006-08-26 06:46:17 +0000
commit967e0c11eaecf01a8596b8b48e8ef8edc85318fd (patch)
treea2a82cd27535db0155b670dda7c96133d0d2fe6e /tests/ls/Makefile.am
parent0d41cd8f2927d896f373fb6076c2508c9284a978 (diff)
downloadcoreutils-967e0c11eaecf01a8596b8b48e8ef8edc85318fd.tar.xz
"ls --color" would highlight other-writable and sticky directories
no differently than regular directories on a file system with dirent.d_type support. * NEWS: Say the above. * src/ls.c (gobble_file): With --color, also stat the file when we know it is a directory. Derived from an anonymous one-line fix and bug report: <https://savannah.gnu.org/bugs/?15043>. * tests/ls/color-dtype-dir: New file. Test for the above fix. * tests/ls/Makefile.am (TESTS): Add color-dtype-dir.
Diffstat (limited to 'tests/ls/Makefile.am')
-rw-r--r--tests/ls/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/ls/Makefile.am b/tests/ls/Makefile.am
index add9988c1..9be242345 100644
--- a/tests/ls/Makefile.am
+++ b/tests/ls/Makefile.am
@@ -21,6 +21,7 @@
AUTOMAKE_OPTIONS = 1.2 gnits
TESTS = \
+ color-dtype-dir \
stat-failed \
stat-dtype \
inode dangle file-type recursive dired infloop \