summaryrefslogtreecommitdiff
path: root/tests/ln/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-11-18 20:00:39 +0100
committerJim Meyering <jim@meyering.net>2006-11-18 20:00:39 +0100
commit0cafba44bbef7c5eb64979544a1ec95a389ec55f (patch)
tree7bfbb62a72231e651643c6545b5f00f697be1254 /tests/ln/Makefile.am
parent1a0333565f1a89d87b36e7a5c83bac9c145a9916 (diff)
downloadcoreutils-0cafba44bbef7c5eb64979544a1ec95a389ec55f.tar.xz
"ln --backup f f" produces a misleading diagnostic:
ln: creating hard link `f' => `f': No such file or directory * src/ln.c (do_link): Give a better diagnostic in this unusual case. (do_link): Rename local: s/lstat_ok/dest_lstat_ok/. * tests/ln/Makefile.am (TESTS): Add hard-backup. * tests/ln/hard-backup: New test for the above.
Diffstat (limited to 'tests/ln/Makefile.am')
-rw-r--r--tests/ln/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/ln/Makefile.am b/tests/ln/Makefile.am
index 8048a9852..79bedce31 100644
--- a/tests/ln/Makefile.am
+++ b/tests/ln/Makefile.am
@@ -1,7 +1,7 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-.
AUTOMAKE_OPTIONS = 1.2 gnits
-TESTS = target-1 sf-1 misc backup-1
+TESTS = hard-backup target-1 sf-1 misc backup-1
EXTRA_DIST = $(TESTS)
TESTS_ENVIRONMENT = \
PATH="$(VG_PATH_PREFIX)`pwd`/../../src$(PATH_SEPARATOR)$$PATH"