summaryrefslogtreecommitdiff
path: root/tests/cp/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-07-28 18:49:04 +0200
committerJim Meyering <jim@meyering.net>2007-07-29 12:03:15 +0200
commit288524b39b2a4c4d1669b16e4a6e0cefc7ed8912 (patch)
tree800225e6c5f2e8c7c4335a9420b97a9f25887279 /tests/cp/Makefile.am
parent26468bd5a2bab9585ea622bbe05a102551663c18 (diff)
downloadcoreutils-288524b39b2a4c4d1669b16e4a6e0cefc7ed8912.tar.xz
Attempt to copy a regular file, even if stat says it is empty.
* NEWS: Document this bug fix. * src/copy.c (copy_reg): Read from a regular file, even if it appears (stat.st_size == 0) to be empty. This reverts an optimization introduced on 2005-11-23 for coreutils-6.0. Otherwise, "cp /proc/cpuinfo /tmp" creates an empty file, on e.g., linux-2.6.20. * tests/cp/proc-zero-len: New file. Test for the above. * tests/cp/Makefile.am (TESTS): Add proc-zero-len. Reported by Dan Berrangé.
Diffstat (limited to 'tests/cp/Makefile.am')
-rw-r--r--tests/cp/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/cp/Makefile.am b/tests/cp/Makefile.am
index e3978c517..ecb718174 100644
--- a/tests/cp/Makefile.am
+++ b/tests/cp/Makefile.am
@@ -16,6 +16,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
TESTS = \
+ proc-zero-len \
thru-dangling \
cp-a-selinux \
file-perm-race parent-perm-race \