summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-02-12 19:35:25 +0100
committerJim Meyering <jim@meyering.net>2007-03-29 21:37:06 +0200
commitadd8b3614847cacba66662ee701d0ce2f3e36802 (patch)
treeda27f455d51d24364c9e03365c3cdbb8f3566f6e /tests/Makefile.am
parentc6922b6f7e3ed8c0d565f588df3bd4daf6635f2b (diff)
downloadcoreutils-add8b3614847cacba66662ee701d0ce2f3e36802.tar.xz
Arrange for "make check-root" to run the new root-only test.
* tests/Makefile.am (t9): New target, to run tests/cp/cp-a-selinux. (all_t): Add t9. Use a directory on a loopback device mounted with -o context=... * tests/cp/cp-a-selinux: Since this test now runs mount and umount, it is a root-only one.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b2cbbfc09..4371d73a9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,7 +30,7 @@ SUBDIRS = \
tsort unexpand uniq wc
## N O T E :: Please do not add new directories.
-all_t = t1 t2 t3 t4 t5 t6 t7 t8
+all_t = t1 t2 t3 t4 t5 t6 t7 t8 t9
.PHONY: check-root $(all_t)
check-root: $(all_t)
@@ -50,6 +50,8 @@ t7:
cd ls && $(MAKE) check TESTS=nameless-uid
t8:
cd misc && $(MAKE) check TESTS=chcon
+t9:
+ cd cp && $(MAKE) check TESTS=cp-a-selinux
check-recursive: root-hint