summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-07-16 19:51:05 +0000
committerJim Meyering <jim@meyering.net>2003-07-16 19:51:05 +0000
commit9416c7da099f5d65ff1a65f29b7b4336159e9167 (patch)
treeb18ec7ec6b3675785a85009f7d04117724c0dfa1 /tests/Makefile.am
parent81b607d2a05b87892b354691b1fc866e865ede1c (diff)
downloadcoreutils-9416c7da099f5d65ff1a65f29b7b4336159e9167.tar.xz
(all_programs): Define.
(TESTS_ENVIRONMENT): Use it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f220f9d71..e8506ad2e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,8 +1,13 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-.
+all_programs = \
+ echo 'spy:;@echo $$(all_programs)' \
+ | MAKEFLAGS= $(MAKE) -s -C $(srcdir)/../src -f Makefile -f - spy \
+ | fmt -1 | sort -u
+
TESTS = help-version
TESTS_ENVIRONMENT = \
- all_programs="$(bin_SCRIPTS) $(bin_PROGRAMS)"
+ all_programs="`$(all_programs)`"
EXTRA_DIST = \
$(TESTS) .env-warn Fetish.pm Makefile.am.in README envvar-check \