summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2008-03-28 22:55:31 +0000
committerJim Meyering <meyering@redhat.com>2008-06-06 14:16:45 +0200
commit75e0047c4b916393b6be3cb985c4c4d4a2d1a836 (patch)
treeac520fe47c6ba9fa6a725d47ba6f20eb4be5ddc5 /tests/Makefile.am
parent74c0bfbc4cf0b38c9c8af7b018f8bbff60da6767 (diff)
downloadcoreutils-75e0047c4b916393b6be3cb985c4c4d4a2d1a836.tar.xz
Add new program: truncate
* AUTHORS: Register as the author * NEWS: Mention this change * README: Add truncate command to list * src/truncate.c: New command * src/Makefile.am: Add truncate command to list to build * src/.gitignore: Add truncate binary to list to ignore * doc/coreutils.texi (truncate invocation): Add truncate info * man/Makefile.am: Add truncate man page to list to build * man/truncate.x: Add truncate man page template * po/POTFILES.in: Add truncate to list to translate * tests/Makefile.am: Add truncate tests * tests/misc/help-version: Add support for new truncate command * tests/misc/truncate-dangling-symlink: check dangling link ok * tests/misc/truncate-dir-fail: ensure dirs fail * tests/misc/truncate-fail-diag: validate messages for missing paths * tests/misc/truncate-fifo: ensure fifos ignored * tests/misc/truncate-no-create-missing: ensure -c option honoured * tests/misc/truncate-overflow: check signed integer overflows * tests/misc/truncate-owned-by-other: root permissions check * tests/misc/truncate-parameters: check invalid parameter combinations * tests/misc/truncate-relative: check invalid relative sizes
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e5042b96b..bc1729945 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -28,6 +28,7 @@ root_tests = \
ls/nameless-uid \
misc/chcon \
misc/selinux \
+ misc/truncate-owned-by-other \
mkdir/writable-under-readonly \
mv/sticky-to-xpart \
rm/fail-2eperm \
@@ -212,6 +213,14 @@ TESTS = \
misc/timeout \
misc/timeout-parameters \
misc/tr \
+ misc/truncate-dangling-symlink \
+ misc/truncate-dir-fail \
+ misc/truncate-fail-diag \
+ misc/truncate-fifo \
+ misc/truncate-no-create-missing \
+ misc/truncate-overflow \
+ misc/truncate-parameters \
+ misc/truncate-relative \
misc/tsort \
misc/tty-eof \
misc/unexpand \