summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-07-25 11:31:01 +0200
committerJim Meyering <meyering@redhat.com>2011-07-25 14:15:44 +0200
commitf28a09810b7dc11261cb43e2a09726caf9a993b7 (patch)
tree5fd2afa981e816f28eaa8aba4a189620a032abfe /tests/Makefile.am
parentaeb5222a6d7f7e9be5b737e2dbaf71185a9946db (diff)
downloadcoreutils-f28a09810b7dc11261cb43e2a09726caf9a993b7.tar.xz
cp -up: preserve all hard links
* src/copy.c (copy_internal): With --update (-u), this function would return early once it found that the destination is not older than the source, *without* recording the source-dev/ino--to--dest_name mapping. That mapping is required in order to preserve src hard links in the destination tree, so when using cp with --update and --preserve=links (perhaps via -p or -a), cp could fail to preserve one hard link per inode when at least one of the hard-linked names already exists in the destination tree. Reported by Odd Harry Mannsverk in http://debbugs.gnu.org/8419. * tests/cp/preserve-link: New file. Exercise the flaw/fix. * tests/Makefile.am (TESTS): Add it. * NEWS (Bug fixes): Mention it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ebd1b1121..0a83dae79 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -341,6 +341,7 @@ TESTS = \
cp/parent-perm-race \
cp/perm \
cp/preserve-2 \
+ cp/preserve-link \
cp/preserve-slink-time \
cp/proc-short-read \
cp/proc-zero-len \