summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-01-05 11:45:50 +0100
committerJim Meyering <meyering@redhat.com>2012-01-30 20:43:07 +0100
commitd1b0155d805ce51d8f155e648d1e9ad2edb95397 (patch)
treeaa83b8c100173f6a5179eaf3e5503021c4337f63 /tests/Makefile.am
parent67ebdb9f20465a0ba1084902230704f410edde3b (diff)
downloadcoreutils-d1b0155d805ce51d8f155e648d1e9ad2edb95397.tar.xz
mv: allow moving symlink onto same-inode dest with >= 2 hard links
Normally, mv detects a few subtle cases in which proceeding with a same-file rename would, with very high probability, cause data loss. Here, we have found a corner case in which one of these same-inode tests makes mv refuse to perform a useful operation. Permit that corner case. * src/copy.c (same_file_ok): Detect/exempt this case. * tests/mv/symlink-onto-hardlink: New test. * tests/Makefile.am (TESTS): Add it. * NEWS (Bug fixes): Mention it. Initially reported by: Matt McCutchen in http://bugs.gnu.org/6960. Raised again by Anders Kaseorg due to http://bugs.debian.org/654596. Improved-by: Paul Eggert.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8b670fc40..a94aaa26f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -491,6 +491,7 @@ TESTS = \
mv/part-symlink \
mv/partition-perm \
mv/perm-1 \
+ mv/symlink-onto-hardlink \
mv/to-symlink \
mv/trailing-slash \
mv/update \