summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-03-02 19:16:46 +0100
committerJim Meyering <meyering@redhat.com>2011-03-03 09:05:44 +0100
commitcaaf2899f67d312d76af91add2a4d9f7be2d5c61 (patch)
tree5b11c3ce27d9d74b258f7720fd2e3130617d0a20 /tests/Makefile.am
parent7cfd12c78e0be4c90f29c99ab383163aa1471504 (diff)
downloadcoreutils-caaf2899f67d312d76af91add2a4d9f7be2d5c61.tar.xz
du: don't infloop for --files0-from=DIR
* src/du.c (main): Fail on AI_ERR_READ error, rather than merely diagnosing and continuing. Based on a patch by Stefan Vargyas. Also move the handling of AI_ERR_EOF into the case stmt. Do not report ferror/fclose(stdin) failure when we've already diagnosed e.g., failure to read the DIR, above. Bug introduced by 2008-11-24 commit 031e2fb5, "du: read and process --files0-from= input a name at a time,". * src/wc.c: Handle read failure as with du: do not exit immediately, but rather go on to print any total and to clean-up. As above, move the handling of AI_ERR_EOF into the case stmt. * tests/du/files0-from-dir: New file, to test both du and wc. * tests/Makefile.am (TESTS): Add it. * NEWS (Bug fixes): Mention it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9603441b0..28eafe8ae 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -370,6 +370,7 @@ TESTS = \
du/exclude \
du/fd-leak \
du/files0-from \
+ du/files0-from-dir \
du/hard-link \
du/inacc-dest \
du/inacc-dir \