summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-04-17 18:44:18 +0200
committerJim Meyering <meyering@redhat.com>2009-04-22 21:52:11 +0200
commitc74fbaefebe91ca60e3a8582613a3714c740df65 (patch)
tree45dcb7277ba56f6f879f1d64444643038791a49a /tests/Makefile.am
parent2ad7da759490a5680844e1e4b6b4ac1d13b95d3b (diff)
downloadcoreutils-c74fbaefebe91ca60e3a8582613a3714c740df65.tar.xz
cp: work around linux kernel bug: short-read != EOF on /proc
Remove the optimization that avoided up to 50% of cp's read syscalls. Do not assume that a short read on a regular file indicates EOF. When reading from a file in /proc on linux [at least 2.6.9 - 2.6.29] into a 4k-byte buffer or larger, a short read does not always indicate EOF. For example, "cp /proc/slabinfo /tmp" copies only 4068 of the total 7493 bytes. This optimization (25719a33154f0c62ea9881f0c79ae312dd4cec7a, Improve performance a bit by optimizing away; 2005-11-24) appears to have been worth less than a 2% speed-up (and usually much less), so the impact of removing it is negligible. * src/copy.c (copy_reg): Don't exit the loop early. * tests/cp/proc-short-read: New test, lightly based on a suggestion from Mike Frysinger, to exercise this fix. * tests/Makefile.am (TESTS): Add cp/proc-short-read. * NEWS (Improve robustness): Mention this change.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ce6a2118..c02f2de93 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -281,6 +281,7 @@ TESTS = \
cp/parent-perm-race \
cp/perm \
cp/preserve-2 \
+ cp/proc-short-read \
cp/proc-zero-len \
cp/r-vs-symlink \
cp/same-file \