summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2011-02-11 08:55:22 +0000
committerPádraig Brady <P@draigBrady.com>2011-04-01 15:04:18 +0100
commitbfdb6b585b6842362977b8c10fe7858fb96a1dd0 (patch)
tree0279e6e1674d34072ba8e7bf94ba929f332e54e4 /tests/Makefile.am
parentb56b53bd70b1f8fa2b5a95d4569bb72a2419b5cd (diff)
downloadcoreutils-bfdb6b585b6842362977b8c10fe7858fb96a1dd0.tar.xz
copy: process empty extents more efficiently
* src/copy.c (extent_copy): Treat an allocated but empty extent much like a hole. I.E. don't read data we know is going to be NUL. Also we convert the empty extent to a hole only when SPARSE_ALWAYS so that the source and dest have the same allocation. This will be improved soon, when we use fallocate() to do the allocation. * tests/cp/fiemap-empty: A new test for efficiency and correctness of copying empty extents. * tests/Makefile.am: Reference the new test. * NEWS: Mention the change in behavior.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e7f3fffb1..685eb52b9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -321,8 +321,9 @@ TESTS = \
cp/dir-vs-file \
cp/existing-perm-race \
cp/fail-perm \
- cp/fiemap-perf \
- cp/fiemap-2 \
+ cp/fiemap-empty \
+ cp/fiemap-perf \
+ cp/fiemap-2 \
cp/file-perm-race \
cp/into-self \
cp/link \