summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Scrivano <gscrivano@gnu.org>2009-06-02 08:28:23 +0200
committerJim Meyering <meyering@redhat.com>2009-06-15 18:34:14 +0200
commitae494d4be80df2aff50a2ac46fdc0c23de109ea3 (patch)
treeca567ba9ae1d870b139778df835707eb1e358ee2 /tests/Makefile.am
parent358aca5fb9cb67c593aa5f1ddf166dbefcf55f0c (diff)
downloadcoreutils-ae494d4be80df2aff50a2ac46fdc0c23de109ea3.tar.xz
tail: use inotify if it is available
* NEWS: Document the new feature. * m4/jm-macros.m4: Check if inotify is present. * src/tail.c (tail_forever_inotify): New function. (main): Use the inotify-based function, if possible. * tests/Makefile.am: Add new tests for tail. * tests/test-lib.sh (require_proc_pid_status_, get_process_status_): New functions. * tests/tail-2/pid: New file. * tests/tail-2/wait: New file. * tests/tail-2/tail-n0f: Refactor code into the test-lib.sh require_proc_pid_status_ function.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2405ce44f..24f54baef 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -137,6 +137,7 @@ TESTS = \
misc/date-next-dow \
misc/ptx-overrun \
misc/xstrtol \
+ tail-2/pid \
misc/od \
misc/mktemp \
misc/arch \
@@ -243,6 +244,7 @@ TESTS = \
misc/unexpand \
misc/uniq \
misc/xattr \
+ tail-2/wait \
chmod/c-option \
chmod/equal-x \
chmod/equals \