summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2005-01-30 14:28:36 +0000
committerJim Meyering <jim@meyering.net>2005-01-30 14:28:36 +0000
commit828850baaaf31e6a879b1e0ca286e8d7b47af84e (patch)
tree342a9fb6306b38cd8754f4184ceae6f545cc8a61 /tests/Makefile.am
parenta13d89b58f0b0bd866edc404ec839fd2312245f1 (diff)
downloadcoreutils-828850baaaf31e6a879b1e0ca286e8d7b47af84e.tar.xz
(.PHONY): Add check-root and root-hint.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4952ee68d..6289d8d94 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,6 +24,7 @@ SUBDIRS = \
rm rmdir seq sha1sum shred sort stty sum tac tail tail-2 test touch \
tr tsort unexpand uniq wc
+.PHONY: check-root
check-root:
cd chown && $(MAKE) check TESTS=basic
cd cp && $(MAKE) check TESTS=special-bits
@@ -41,6 +42,7 @@ evar-check:
&& sed s/%%/CDPATH/ $(srcdir)/.env-warn || :
# Advertise `check-root' target.
+.PHONY: root-hint
root-hint:
@echo '***********************************************************'
@echo "NOTICE: Some tests may be run only as root."