summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2010-10-23 17:20:01 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2010-10-23 17:24:38 -0700
commit7d93a082b6e3ece0b120a5150d2020c7fa11b2f5 (patch)
treebf963fe6dfed9a7451f2a6e73d972f16ec14c4c4 /tests/Makefile.am
parentd5d82ecf3b0f370216c12e0f8163f0a5249da91e (diff)
downloadcoreutils-7d93a082b6e3ece0b120a5150d2020c7fa11b2f5.tar.xz
du: don't print junk when diagnosing out-of-range time stamps
* src/du.c (show_date): Fix call to fputs with a buffer that contains some uninitialized data. * tests/Makefile.am (TESTS): Add du/big-timestamp. * tests/du/bigtime: New file, which checks for the bug.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 41e0cbce7..84db367b1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -346,6 +346,7 @@ TESTS = \
du/2g \
du/8gb \
du/basic \
+ du/bigtime \
du/deref \
du/deref-args \
du/exclude \