summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2011-03-31 11:28:58 +0100
committerPádraig Brady <P@draigBrady.com>2011-04-01 14:17:27 +0100
commit594292a1d89332dd006cd7fe3116cf46ebe9acf6 (patch)
tree75db5403a519f0e3c501129f1302af352e0827e5 /tests/Makefile.am
parent0ec711b5c4c5094fa206115a666e5878f463a07f (diff)
downloadcoreutils-594292a1d89332dd006cd7fe3116cf46ebe9acf6.tar.xz
copy: link rather than copy symlinks, when --link used
This bug was introduced in commit ca9e212c, 2009-09-24, "cp, mv: use linkat to guarantee semantics", which inadvertently disabled the creation of hardlinks to symlinks. However rather than implementing the intention of that commit and relying on gnulib linkat emulation, we'll revert to the previous emulation as that maintains ownership and timestamps. * src/copy.c (copy_internal): Use our existing hardlink to symlink emulation when link() might dereference the symlink. Also ensure that we copy the timestamps of the original symlink when we use the emulation. * tests/cp/link-symlink: Add a test to ensure timestamps copied. * tests/Makefile.am: Reference the new test. * NEWS: Mention the fix. Reported by Ruediger Meier
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 99b46e8e8..e7f3fffb1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -328,6 +328,7 @@ TESTS = \
cp/link \
cp/link-no-deref \
cp/link-preserve \
+ cp/link-symlink \
cp/no-deref-link1 \
cp/no-deref-link2 \
cp/no-deref-link3 \