summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-09-27 16:32:35 +0200
committerJim Meyering <meyering@redhat.com>2011-09-27 16:49:51 +0200
commit57ee5493d996b69a02d367829d579729e8b20eaf (patch)
treed529aabd8f561ba816e3da9f2cef70078eec1eca /tests/Makefile.am
parent1d0a7ed7d58cfcc2f44959fed431e7276bdf1d46 (diff)
downloadcoreutils-57ee5493d996b69a02d367829d579729e8b20eaf.tar.xz
sort: avoid a NaN-induced infloop
These commands would fail to terminate: yes -- -nan | head -156903 | sort -g > /dev/null echo nan > F; sort -m -g F F That can happen with any strtold implementation that includes uninitialized data in its return value. The problem arises in the mergefps function when bubble-sorting the two or more lines, each from one of the input streams being merged: compare(a,b) returns 64, yet compare(b,a) also returns a positive value. With a broken comparison function like that, the bubble sort never terminates. Why do the long-double bit strings corresponding to two identical "nan" strings not compare equal? Because some parts of the result are uninitialized and thus depend on the state of the stack. For more details, see http://bugs.gnu.org/9612. * src/sort.c (nan_compare): New function. (general_numcompare): Use it rather than bare memcmp. Reported by Aaron Denney in http://bugs.debian.org/642557. * NEWS (Bug fixes): Mention it. * tests/misc/sort-NaN-infloop: New file. * tests/Makefile.am (TESTS): Add it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eeb4cab2d..2cf409ae9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -250,6 +250,7 @@ TESTS = \
misc/sort-unique \
misc/sort-unique-segv \
misc/sort-version \
+ misc/sort-NaN-infloop \
split/filter \
split/suffix-length \
split/b-chunk \