summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-10-16 12:07:05 +0200
committerJim Meyering <meyering@redhat.com>2011-10-17 17:44:54 +0200
commit537f9da37fa396af72d8b3e6af274e0bcbeab794 (patch)
tree80c465e50d6b124ccc56b6bf7764738480f65559 /tests/Makefile.am
parent60cd4c271d35eb94bbf04e07425502ed3bb8697c (diff)
downloadcoreutils-537f9da37fa396af72d8b3e6af274e0bcbeab794.tar.xz
tac: don't misbehave with multiple non-seekable inputs
* src/tac.c (copy_to_temp): Do not reuse the template buffer. Instead, scribble only on a freshly-xstrdup'd copy each time. Free that buffer both here, upon failure, and ... (tac_nonseekable): ...free the buffer in caller, upon success. * tests/misc/tac-2-nonseekable: New file. * tests/Makefile.am (TESTS): Add it. * NEWS (Bug fixes): Mention it. Reported by Ambrose Feinstein in http://debbugs.gnu.org/9762.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9c9a1b8c1..5021c1844 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -274,6 +274,7 @@ TESTS = \
misc/sum-sysv \
misc/tac \
misc/tac-continue \
+ misc/tac-2-nonseekable \
misc/tail \
misc/tee \
misc/tee-dash \