summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2011-11-11 23:21:13 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2011-11-11 23:21:50 -0800
commit448718c123838891500afa7fbda06335e7258592 (patch)
tree8c0bb1d206db461f72cd4a192e0a439d980466c9 /tests/Makefile.am
parent1d9fe527a0ff85ca757a74338c5f1b523473b377 (diff)
downloadcoreutils-448718c123838891500afa7fbda06335e7258592.tar.xz
ls: -k no longer affects -l's file sizes
This fixes an incompatibility with POSIX 2008 and with BSD. Problem reported by Abdallah Clark (Bug#9939) via Alan Curry (Bug#10016). * NEWS: Document this. * doc/coreutils.texi (General output formatting): Document the new -k behavior, and --kibibytes. * src/ls.c (file_human_output_opts): New static var. (long_options, usage): Add --kibibytes. (decode_switches, gobble_file, print_long_format): Implement the new -k behavior. * tests/ls/block-size: New file. * tests/Makefile.am (TESTS): Add it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5021c1844..64366a491 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -415,6 +415,7 @@ TESTS = \
ln/slash-decorated-nonexistent-dest \
ln/target-1 \
ls/abmon-align \
+ ls/block-size \
ls/color-clear-to-eol \
ls/color-dtype-dir \
ls/color-norm \