summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-08-15 06:53:38 +0000
committerJim Meyering <jim@meyering.net>2003-08-15 06:53:38 +0000
commit2faafb85123a032357c4a01678feb9f65bbdcb52 (patch)
tree77466d8bebb9b63b10c32092767e814b58227038 /tests/Makefile.am
parent4f6b3338a1e43464f6ecb0e580878d52267f47f0 (diff)
downloadcoreutils-2faafb85123a032357c4a01678feb9f65bbdcb52.tar.xz
(ASSORT): New var.
(all_programs): Use it.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 77ddaa999..6e89a5d30 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,9 +1,14 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-.
+# Sort in traditional ASCII order, regardless of the current locale;
+# otherwise we may get into trouble with distinct strings that the
+# current locale considers to be equal.
+ASSORT = LC_ALL=C sort
+
all_programs = \
echo 'spy:;@echo $$(all_programs)' \
| MAKEFLAGS= $(MAKE) -s -C ../src -f Makefile -f - spy \
- | fmt -1 | sort -u
+ | fmt -1 | $(ASSORT) -u
TESTS = help-version
TESTS_ENVIRONMENT = \