summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-09-02 21:55:11 +0200
committerJim Meyering <meyering@redhat.com>2012-09-05 08:48:29 +0200
commit24fb6d91b6b5b460d5d0b4f5c76d4a954f928040 (patch)
tree52f463ff5d67add3e208f93bdf608d5107dc09a6 /tests/Makefile.am
parent84f5176fcdc8a4015dc3cf8100686b8e8be0c894 (diff)
downloadcoreutils-24fb6d91b6b5b460d5d0b4f5c76d4a954f928040.tar.xz
maint: list of names of built programs available in the Makefiles
This is just a preparatory refactoring in view of future changes. * configure.ac (AC_SUBST): New 'built_programs'. * tests/Makefile.am (AM_TESTS_ENVIRONMENT): Simply define the exported variable 'built_programs' to the expansion of the '$(built_programs)' AC_SUBST'd make variable. (.built-programs): Remove this now-unneeded convenience target. (CLEANFILES, check_DATA): Delete, no longer needed.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 1 insertions, 9 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2ef2f10fa..56ca499b7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -39,14 +39,6 @@ vc_exe_in_TESTS:
check-local: vc_exe_in_TESTS
.PHONY: vc_exe_in_TESTS
-CLEANFILES =
-CLEANFILES += .built-programs
-check_DATA = .built-programs
-.built-programs: $(top_srcdir)/Makefile.am
- $(AM_V_GEN)(cd $(top_builddir) \
- && MAKEFLAGS= $(MAKE) -s built_programs.list) \
- | sed s,^src/,, > $@-t && mv $@-t $@
-
TEST_EXTENSIONS = .sh .pl .xpl
if HAVE_PERL
@@ -86,7 +78,7 @@ AM_TESTS_ENVIRONMENT = \
abs_top_builddir='$(abs_top_builddir)' \
abs_top_srcdir='$(abs_top_srcdir)' \
abs_srcdir='$(abs_srcdir)' \
- built_programs="`cat .built-programs`" \
+ built_programs='$(built_programs)' \
host_os=$(host_os) \
host_triplet='$(host_triplet)' \
srcdir='$(srcdir)' \