summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2010-11-10 14:35:17 +0000
committerPádraig Brady <P@draigBrady.com>2010-11-11 01:40:12 +0000
commit0339eb4598600024cedca14a7e882c1737dd2d82 (patch)
treea83d8af40ed3fa2382f8720c0f74aaa8fad644f3 /tests/Makefile.am
parent7727908335ef1049deac42851026ed8bf5ae2734 (diff)
downloadcoreutils-0339eb4598600024cedca14a7e882c1737dd2d82.tar.xz
csplit: fix a memory leak per input buffer
* src/csplit.c (free_buffer): Also free the line offsets buffers (remove_line): Also free the containing structure * tests/misc/csplit-heap: A new test to trigger with leaks of this magnitude. * tests/Makefile.am: Reference the new test * NEWS: Mention the fix Reported by David Hofstee
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a3a30b6bd..90ff292a1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -173,6 +173,7 @@ TESTS = \
misc/comm \
misc/csplit \
misc/csplit-1000 \
+ misc/csplit-heap \
misc/date-sec \
misc/dircolors \
misc/df \