summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGiuseppe Scrivano <gscrivano@gnu.org>2009-10-20 10:49:17 +0200
committerJim Meyering <meyering@redhat.com>2009-10-22 10:25:58 +0200
commit029b6b14c5c4eba3071cac835efd5b277ff2337a (patch)
tree1cdb8cfb290473c4226dd181f03e2f7e90ca0203 /tests/Makefile.am
parentcd0f3036f606276654f2293a4d90df5efd21bd99 (diff)
downloadcoreutils-029b6b14c5c4eba3071cac835efd5b277ff2337a.tar.xz
tests: add a test for the `tail -f' race condition bug
If new data becomes available between the initial read and when tail registers the inotify watch descriptors, ensure that it is read before a new event happens on the file. * tests/Makefile.am (TESTS): Add tail-2/inotify-race. * tests/tail-2/inotify-race: New file.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 62583477b..ae17e9fe2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -74,6 +74,7 @@ EXTRA_DIST += $(TESTS)
TESTS = \
misc/help-version \
+ tail-2/inotify-race \
misc/invalid-opt \
rm/ext3-perf \
rm/cycle \