summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-03-28 07:57:51 +0200
committerJim Meyering <meyering@redhat.com>2011-03-28 11:51:35 +0200
commitfde07ff436ef19cc85a8bb626535cc18fdb9d588 (patch)
tree1472576870c00844f4216551bda5479507e0c165 /src/Makefile.am
parent99679fff629f4a624f4fe7a67335c6e90533afc2 (diff)
downloadcoreutils-fde07ff436ef19cc85a8bb626535cc18fdb9d588.tar.xz
maint: correct formatting style in a header
* src/find-mount-point.h: Move "*" to where it belongs. Move "const", too. * src/find-mount-point.c: Move "const" to conform. * src/Makefile.am (sc_tight_scope): Allow `*'s before the function name. Use perl's -l option and drop the \n after (and quotes around) $1.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bf1d60a88..5bd71d258 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -727,7 +727,8 @@ sc_tight_scope: $(bin_PROGRAMS)
( printf 'main\nusage\n_.*\n'; \
grep -h -A1 '^extern .*[^;]$$' $$src \
| grep -vE '^(extern |--)' | sed 's/ .*//'; \
- perl -ne '/^extern (?:enum )?\S+ (\S*) \(/ and print "$$1\n"' $$hdr; \
+ perl -lne '/^extern (?:enum )?\S+ \**(\S*) \(/ and print $$1' \
+ $$hdr; \
) | $(ASSORT) -u | sed 's/^/^/;s/$$/$$/' > $$t; \
nm -e *.$(OBJEXT) \
| sed -n 's/.* T //p' \
@@ -736,7 +737,7 @@ sc_tight_scope: $(bin_PROGRAMS)
{ echo 'the above functions should have static scope' 1>&2; \
exit 1; } || : ; \
( printf '^program_name$$\n'; \
- perl -ne '/^extern .*?\**(\w+);/ and print "^$$1\$$\n"' \
+ perl -lne '/^extern .*?\**(\w+);/ and print "^$$1\$$"' \
$$hdr *.h ) | $(ASSORT) -u > $$t; \
nm -e *.$(OBJEXT) \
| sed -n 's/.* [BD] //p' \