summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAaron Burgemeister <dajoker@gmail.com>2010-07-15 19:54:49 -0600
committerPádraig Brady <P@draigBrady.com>2010-08-27 22:16:10 +0100
commitddf6fb8686b1ed6a26d5f1c76a642d0fb5fe7ba7 (patch)
tree27c8712c7d87a57181506c24f2b2ebb58769646c /src/Makefile.am
parent872f6bb2ba11c61271bf34057a2e950abb3e952e (diff)
downloadcoreutils-ddf6fb8686b1ed6a26d5f1c76a642d0fb5fe7ba7.tar.xz
stat: add %m to output the mount point for a file
* src/find-mount-point.c: A new file refactoring find_mount_point() out from df.c * src/find-mount-point.h: Likewise. * src/df.c: Use the new find-mount-point module. * src/stat.c (print_stat): Handle the new %m format. (find_bind_mount): A new function to return the bind mount for a file if any. (out_mount_mount): Print the bind mount for a file, or else the standard mount point given by the find-mount-point module. (usage): Document the %m format directive. * src/Makefile.am: Reference the refactored find-mount-point.c * po/POTFILES.in: Add find_mount_point.c to the translation list * doc/coreutils.texi (stat invocation): Document %m, and how it may differ from the mount point that df outputs. * test/misc/stat-mount: A new test to correlate mount points output from df and stat. * tests/Makefile.am: Reference the new test. * NEWS: Mention the new feature * THANKS: Add the author Signed-off-by: Pádraig Brady <P@draigBrady.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1a19fa611..00c7ff713 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -145,6 +145,7 @@ noinst_HEADERS = \
copy.h \
cp-hash.h \
dircolors.h \
+ find-mount-point.h \
fs.h \
group-list.h \
ls.h \
@@ -478,6 +479,9 @@ rm_SOURCES = rm.c remove.c
mkdir_SOURCES = mkdir.c prog-fprintf.c
rmdir_SOURCES = rmdir.c prog-fprintf.c
+df_SOURCES = df.c find-mount-point.c
+stat_SOURCES = stat.c find-mount-point.c
+
uname_SOURCES = uname.c uname-uname.c
arch_SOURCES = uname.c uname-arch.c
nproc_SOURCES = nproc.c