summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-08-28 18:24:48 +0200
committerJim Meyering <jim@meyering.net>2007-08-28 18:24:54 +0200
commitd6d5658df6cde248948fe411938140b0139767eb (patch)
treeb8cfd54b5e78306d014e21cf1b8d569c14af7a2f /src/Makefile.am
parentc370a7e62f651006b9b1816eada98c8a23961431 (diff)
downloadcoreutils-d6d5658df6cde248948fe411938140b0139767eb.tar.xz
By default, do not install hostname anymore; no kidding, this time.
* src/Makefile.am (EXTRA_PROGRAMS): Remove hostname from this list, now that it's no longer being installed by default. This should have been part of the 2007-08-21 change. (check-duplicate-no-install): New rule to ensure this doesn't happen again. (check): Depend on it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 43f138c04..6d652a666 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,7 @@ EXTRA_PROGRAMS = \
nl od paste pr ptx sha1sum sha224sum sha256sum sha384sum sha512sum \
shuf sort split sum tac tail tr tsort unexpand uniq wc \
basename date dirname echo env expr factor false \
- hostname id kill logname pathchk printenv printf pwd \
+ id kill logname pathchk printenv printf pwd \
runcon seq sleep tee \
test true tty whoami yes \
base64
@@ -300,7 +300,7 @@ pm = progs-makefile
pr = progs-readme
# Ensure that the list of programs in README matches the list
# of programs we can build.
-check: check-README check-misc
+check: check-README check-misc check-duplicate-no-install
.PHONY: check-README
check-README:
rm -rf $(pr) $(pm)
@@ -311,6 +311,13 @@ check-README:
| sed -n '/^ */s///p' | tr -s ' ' '\n' > $(pr)
diff $(pm) $(pr) && rm -rf $(pr) $(pm)
+# Ensure that a by-default-not-installed program (listed in
+# $(no_install__progs) is not also listed in $(EXTRA_PROGRAMS), because
+# if that were to happen, it *would* be installed by default.
+.PHONY: check-duplicate-no-install
+check-duplicate-no-install: tr
+ test -z "`echo '$(EXTRA_PROGRAMS)'| ./tr ' ' '\n' | uniq -d`"
+
# Ensure that the list of programs and author names is accurate.
au_dotdot = authors-dotdot
au_actual = authors-actual