summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-10-12 11:05:00 +0200
committerJim Meyering <meyering@redhat.com>2008-10-12 11:21:19 +0200
commitc3e1fe230b9858d94299ab6f106d4e37fa4a6d75 (patch)
treec4eccca402c3068e7b863f208eb7766c562f65c1 /src/Makefile.am
parent1833a876ae2497b2bd915b9e1a8f364cef66272e (diff)
downloadcoreutils-c3e1fe230b9858d94299ab6f106d4e37fa4a6d75.tar.xz
tests: move check-misc targets from src/Makefile.am to maint.mk
* src/Makefile.am (check): Remove check-misc. (check-misc): Remove target. * maint.mk (sc_prohibit_stat_st_blocks): New target. (sc_prohibit_S_IS_definition): New target. * Makefile.am (EXTRA_DIST): Add .x-sc_prohibit_stat_st_blocks. * .x-sc_prohibit_stat_st_blocks: New file. Andreas Schwab reported that "make check" could fail to detect violation of the no-S_IS*-definition policy.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 1 insertions, 13 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 362587885..097cc7a2e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -351,7 +351,7 @@ pm = progs-makefile
pr = progs-readme
# Ensure that the list of programs in README matches the list
# of programs we can build.
-check: check-README check-misc check-duplicate-no-install
+check: check-README check-duplicate-no-install
.PHONY: check-README
check-README:
rm -rf $(pr) $(pm)
@@ -391,18 +391,6 @@ check-AUTHORS: $(all_programs)
sed -n '/^[^ ][^ ]*:/p' $(top_srcdir)/AUTHORS > $(au_dotdot)
diff $(au_actual) $(au_dotdot) && rm -f $(au_actual) $(au_dotdot)
-# Make sure we don't define any S_IS* macros in src/*.c files.
-# Not a big deal, but they're already defined via system.h.
-#
-# Also make sure we don't use st_blocks. Use ST_NBLOCKS instead.
-# This is a bit of a kludge, since it prevents use of the string
-# even in comments, but for now it does the job with no false positives.
-.PHONY: check-misc
-check-misc:
- cd $(srcdir); grep '^# *define *S_IS' $(SOURCES) && exit 1 || :
- cd $(srcdir); grep st_blocks $(SOURCES) && exit 1 || :
- cd $(srcdir); grep '^# *define .*defined' $(SOURCES) && exit 1 || :
-
# Extract the list of authors from each file.
sed_filter = s/^ *//;s/N_ (//;s/^"//;s/")*$$//
# Sometimes the string is on the same line as the #define...